Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Does the QV Web Server service need to be started for the QV Management Console to work?

<body><p>Just installed QV Server 10 (Single Machine, full install) on a Windows Server 2008 R2 server.  The url for the Management Console does not appear to be working - url  <style type="text/css"></style> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> <table width="550"> <b><a href="http://localhost:4780/qmc/default.htm">http://localhost:4780/qmc/default.htm</a> <tbody> </tbody> </b> </table> </p> <p>The only QV services that are running after the reboot are:</p> <p>1)  Directory Service Connector</p> <p>2)  Management Service</p> <p>3)  Server</p> <p>Are other pre-requisites required in order for the Management Console to work?  I don't see anything in the manual. </p> <p>Thanks,</p> <p>Michael</p></body>

1 Solution

Accepted Solutions
Not applicable

Does the QV Web Server service need to be started for the QV Management Console to work?

For the consoles to work you do not need the Qlikview Webserver running (for example if using IIS) but you do need Managment Service. The 'log in as' for the service also needs to be defined in the Qlikview Administartors group.

Regards,

Gordon

6 Replies
MVP
MVP

Does the QV Web Server service need to be started for the QV Management Console to work?

Hello Michael,

The QlikView Webserver should be up and running in order to get access to the Management Consoles and the Accesspoint. Did it throw any error to the Windows Event Viewer or the QlikView logs located in C:\ProgramData\QlikTech.

Try manual start and see if that helps

EDIT: N.B.: QlikView Webserver is not needed to get access to the consoles.

Not applicable

Does the QV Web Server service need to be started for the QV Management Console to work?

I see the following "warning" in the WebServer log file:

Warning https error. Exception: System.Net.HttpListenerException: Access is denied

Also, I see these messages in the ManagementService log file:

Error Failed to start backend web server. System.ServiceModel.AddressAccessDeniedException: HTTP could not register URL http://+:4799/QMS/Service/. Your process does not have access rights to this namespace (see http://go.microsoft.com/fwlink/?LinkId=70353 for details). ---> System.Net.HttpListenerException: Access is denied

Error Failed to start QMS web server on port 4780. Exception : System.Net.HttpListenerException: Access is denied

Error Failed to start frontend web server. System.ObjectDisposedException: Cannot access a disposed object.

Error System.ServiceModel.CommunicationObjectFaultedException: The communication object, System.ServiceModel.ServiceHost, cannot be used for communication because it is in the Faulted state.

Have you seen these type of errors before?

Thanks,

Michael

Not applicable

Does the QV Web Server service need to be started for the QV Management Console to work?

The only thing you need running is the Management Service. You won't be able to manage services that aren't running, but to access the management console, that is all you need running.

Not applicable

Does the QV Web Server service need to be started for the QV Management Console to work?

For the consoles to work you do not need the Qlikview Webserver running (for example if using IIS) but you do need Managment Service. The 'log in as' for the service also needs to be defined in the Qlikview Administartors group.

Regards,

Gordon

Not applicable

Does the QV Web Server service need to be started for the QV Management Console to work?

You should have these services set to run under a user with local administrative privileges. That is a common cause of the HTTPListenerException.

MVP
MVP

Does the QV Web Server service need to be started for the QV Management Console to work?

That's correct. Post edited. Thanks