Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

External Program Task Doesn't Run

QlikView 8.5

I have created an External Program Task to run an instance of QV32bit, then run a .qvw file. Here's the command line code:

"C:\QlikView\Developer_X32\Qv.exe" /r "D:\QlikView\Applications\TransferFiles.qvw"

I scheduled it in Publisher on our QA server and it ran perfectly. With this success, I moved the application onto our Prod server, tested it and it runs perfectly too.

Now, I have come back to the QA server several weeks later to make a few changes. I first ran the application "as is" to make sure all was OK before I made changes. It doesn't run. It just hangs when scheduled.

I have extracted the command line prompt from the External Program Task and ran it on the QA server at the DOS prompt and it runs fine. I have looked at all the Publisher settings and QlikView Management Console settings between the QA and Prod servers and the seem identical. I even rebooted the QA server...still no joy.

I have culled thru this forum for help, but can't find anything related.

Any suggestions?

4 Replies
Contributor III

External Program Task Doesn't Run

And you can run this command as a bat file?

Not applicable

External Program Task Doesn't Run

Yes, I probably could. We have used that technique many times when there are multi-line command files or other script files. But, the .bat file would just echo my single command line...just one single line. I am trying desperately to reduce the "baggage" associated with this application. If I write a .bat file, it's another file that needs tending, migrating, etc.

It has worked before and IS working on our Prod server. Could someone have messed with the QA server settings? What should I look for?

I'm in the process of creating a duplicate External Program Task thinking the current one is corrupt. Wish me luck. Yes

It's frustrating when you know you are doing everything right, but the world is against you.


Not applicable

External Program Task Doesn't Run

I have the same problem, did you ever resolve this?

we're using QV9 sr 5

Not applicable

External Program Task Doesn't Run

Do you have changed the user that execute QVS services?