Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Failed to open document

Greetings,

We installed the QVS9 SR2 on Windows 2008 Server and are using a temporary license (1 QVW) to show the features in a company / client. Initially put a default application for viewing the Access Point. After some successful tests, we created an application and set it to be displayed in the Access Point. But to access the Access Point the Browser, when the application is selected to open the following message appears: "Failed to open document, you do not have access to this document." We delete the Authorization tab accesses the application previously set, but this did not resolve. I need help urgently. We have an excellent desktop solution, but the QVS9 has left to be desired.

13 Replies
Not applicable

Failed to open document

it may be a problem with rights on the folder where documents are stored. check the user (or IQVS_* if you use anonymous access) is allowed to list this directory and read the files

Not applicable

Failed to open document

Hi jgeorge,

These checks were carried out. User has full access to the folder where the qvw. We are not using anonymous access. Thank you for your attention.

vgutkovsky
Honored Contributor II

Failed to open document

Since you have an Authorization tab to begin with, I'm assuming you are using DMS authentication. If you delete all entries in the Authorization tab, then nobody is authorized on that document and, therefore, everyone will get the error "Failed to open document." Are you using DMS in combination with AD or a custom directory?

Also, since this is a temporary license, it's possible that DMS is disabled. Please paste the contents of your LEF here (without the serial number).

Not applicable

Failed to open document

Hello Vlad,

I'm using authentication DMS. The application that I want to acces the access point is duly registered with User tab authorization. I am using DMS in conjunction with AD, ie the users using login and password for the network. I gather that the DMS is activated.

FORCE_AUTHENTICATION;YES;;
NUMBER_OF_DOCUMENTS;1;;
NUMBER_OF_USERCALS;100;;
PRODUCTLEVEL;10;;2010-02-15
SPECIAL_EDITION;EVALUATION;;
TIMELIMIT;VALUE;;2010-02-15

vgutkovsky
Honored Contributor II

Failed to open document

Your LEF looks OK--DMS mode is not disabled. There are a couple things you can try to resolve this. First, check your AD settings by going to QEMC --> System --> Directory Service COnnectors --> Active Directory --> General tab. You will see a path to your LDAP here. By default, this path is in basic domain format (something like LDAP://root.testdomain.com). You can try changing this to a distinguished domain format (e.g. LDAP://DC=root,DC=testdomain,DC=com).

It's also important that you specify AD user names in the Authorization tab in the correct format, which for some reason can be very finicky. For example, if the PC is a member of the testdomain.com domain, and the user is Joe, you can specify this user as either Joe or testdomain\Joe, but not testdomain.com\Joe.

Finally, if you are using IIS, make sure that anonymous access settings are consistent. You mentioned that you are not allowing anonymous access. If you are using IIS, you then need to remove Anonymous Authentication on all virtual directories except Scripts and possibly QVPrint, leaving only Windows Authentication.

Regards,

Not applicable

Failed to open document

Vlad thanks for the tips ...
I did the following:

QEMC -> System -> Service Directory Connectors -> Active Directory -> General tab has been changed to LDAP: / / DC = root for example. This the error message changes to: "OCX is prepared for module unload - can not create object".

Thanks

Stive


vgutkovsky
Honored Contributor II

Failed to open document

Stive,

Is the new error message occuring only with the IE Plugin, or with the AJAX client as well?? Try adding the server to the list of Trusted Sites in IE, making sure that "Initialize and script ActiveX controls not marked as safe for scripting" has been allowed for the Trusted Sites zone.

Regards,

Not applicable

Failed to open document

We are also seeing that message, "OCX Module is prepared for unload - cannot create object" when accessing a document, then accessing a different URL, then the mesage appears upon attempting to return to the original QlikView document.

It seems to be related to IE8. Has anyone been able to get past this issue? Any help is appreciated.

Thanks,

- DJ

Not applicable

Failed to open document

More information: Occurs with all plug-ins from 8.2 - 9.0 on Windows 7 (64-bit) with a 32-bit IE8 browser.