Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Full CPU usage QV server service on Win2008R2 x64 with QVS x64 SR5

Hello,

Our customer is installing QV Server v9 x64 SR5 on a dedicated virtual (hosted) server. This server is installed with Windows Server 2008 R2 Standard x64. When we tried to install the server a few days ago, the machine was equipped with 1 processor core and 1 Gb RAM. In between the hardware is upgraded to 2 cores and 4 Gb RAM, but when we reïnstall QVS SR5 x64 we still have the same problem: after installation of Qlikview Server the QVserver service uses 100% capacity of both CPU's. We cannot save changed parameters in QMC because of time-outs.

Has anyone had the same problems?

Please help!

Kind regards,

Patrick Strooij - Provelu

4 Replies
pablolabbe
Not applicable

Full CPU usage QV server service on Win2008R2 x64 with QVS x64 SR5

SR5 have some issues with distribution service. I recommend you to use SR4.

Don´t forget to install .Net 3.5 Framework SP1.

rwunderlich
Not applicable

Full CPU usage QV server service on Win2008R2 x64 with QVS x64 SR5

You might take a look at this thread

http://community.qlik.com/forums/p/25371/101531.aspx

The symptoms don't quite fit, and Mr Backstrand said it would be fixed in SR4. But may be of interest.

I have a couple of SR5 servers running without problem, but they are Win2003.

Do you know if users are accessing documents when the high CPU occurs? Or does it begin right at the service start?

I have seen very slow performance on virtual servers when paging occurs. What's the RAM usage of the machine and the QVS service?

Just some random suggestions and curiosity because I am looking at upgrading a server to Win2008 and wondering if it's a good idea.

Anyone else running SR5 on Win2008 without problems?

-Rob

Stefan_Bäckstrand
Not applicable

Full CPU usage QV server service on Win2008R2 x64 with QVS x64 SR5

Rob, this does not quite match the other issue, no. So I would not rely on SR4 to solve that (and downgrade from SR5 is not recommended, imo). =)

Patrick, I would say that the symptoms are very strange - I have never seen a QVS max out on CPU directly after install. A couple of questions;

1. Have you verified that it is the QVS.exe process that is responsible for all the CPU usage?

2. Does the QVS event logs say anything? Look in "C:\ProgramData\Qliktech" for the QVS folder. If the file does not give anything, and the QEMC does not respond, set the log verbosity on QVS in the registry via HKLM/Software/Qliktech/QlikviewServer/Settings 7/Verbosity" to 1000 and restart the QVS service.

3. Have you made any configuration changes to QVS? Added any documents to the QVS root? Changed the Preload options?

Stefan_Bäckstrand
Not applicable

Full CPU usage QV server service on Win2008R2 x64 with QVS x64 SR5

By the way, I might mention as a notice that we are working on the Distribution Service issues in SR5, and are testing scenarios for a solution right now.