Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Gauge expression doesn't behave well

Hello everyone,

I made a gauge that goes from 0% to 100%. The spire of the gauge goes to 0 when I filter on a field.

I have made a textbox with the same expression that is in the gauge but there, the value doesn't change when I do the same filter.

Here is my expression :

sum({$< libelle = {'Internet'} >}poidsM2)/sum({$< Produit = {'XXX'} , libelle=>} Objectifs)

The result of this expression is 0.73. When I filter on "Internet" for "libelle", the spire goes to 0 in the gauge... I don't get why because I put set analysis in both part of the expression so the filter on libelle shouldn't change anything.

In the textbox, the value is still 0.73 when I do this filter.

Why don't the textbox and the gauge behave the same ?

Thank you for your help.

Have a good day.

Laura

1 Solution

Accepted Solutions
Not applicable

Re: Gauge expression doesn't behave well

I removed all the dimensions and it works !!

Thank you for your help, i really appreciated.

8 Replies

Re: Gauge expression doesn't behave well

May be the gauge chart expression is not changing, but Segments or Min and Max on Presentation tab.

What are some expressions you are using on the presentation tab?

Not applicable

Re: Gauge expression doesn't behave well

Thank you for your replay.

I also thought about that but no, the min and max are not expressions..

For segments, I don't think so but I'm not sure how to check it--> But segments are only about the color, don't they ?

Thank you again,

Laura

Not applicable

Re: Gauge expression doesn't behave well

It looks like the set analysis in the expression of the gauge doesn't work...

When I filter on other values of "libelle", the spire also goes to 0.

Re: Gauge expression doesn't behave well

The min and max and segments can sometimes be determined using expressions. If they are static numbers then it is different thing, but if they are based on expressions, you can see weird things happening

Capture.PNG

Not applicable

Re: Gauge expression doesn't behave well

Thank you for your help.

I have 2 segments and for both, I have min =  and max 1.25.

I have also found out that I put "libelle" in dimension and that when I remove it, the spire also goes to 0.

I don't know what that means. I'm not so confortable with dimension in gauges.

Re: Gauge expression doesn't behave well

Is there a sample you can share to look at?

Not applicable

Re: Gauge expression doesn't behave well

I removed all the dimensions and it works !!

Thank you for your help, i really appreciated.

Re: Gauge expression doesn't behave well

Please close this thread by marking your answer as correct and any helpful answers.

Thanks,

Sunny

Community Browser