Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Group Authorization to documents

Hi,

I´ve been told that it should be possible to use AD groups to authorize qlikview documents. But I can´t work it out.

I use Qlikview Server and Publisher 9.0.7257.6.

DSC is config to use both AD and WinNt. User account running QVS is member om Qlikview Administrators.

Please help!

6 Replies
lhr
Contributor III

Group Authorization to documents

hello,

are you running in DMS mode?

is the DSC and the QVS running on the same machine?

are you using the accesspoint?

can you open documents with "direct" access (e.g., a user is authorized directly and not through a group)?

cheers,

lars

Not applicable

Group Authorization to documents

DMS mode, yes.

DSC and QVS on the same machine.

Using Accesspoint.

Users can open documents, but not via AD groups.

Not applicable

Group Authorization to documents

Im succesfully doing this but noticed some strange behaviour when setting it up, Our domian name contain uppers and lowers and I had to specify the Account as UpperDomain\GroupName.

for some reason it was case significant.

ColinR

Not applicable

Group Authorization to documents

Ok.

I discribe my config and maybe there is something wrong somewhere.

In QEMC under System - Setup - DSC I config Active Directory (ADDOMAIN-NAME) without Autentification, the same for Windows NT (NTDOMAIN-NAME). No config Custom or Local Directory. I did it via "GetDefault" button.

In QMC I can see all my document under User Documents. In Authorization I add reciptients (NTDOMAIN-NAME\group_name or group_name@ADDOMAIN-NAME)

What is missing?

lhr
Contributor III

Group Authorization to documents

you should use the format domain\user for both AD and NT.

second, check the DSC log (found in [AppData]\QlikTech\DirectoryServiceConnector\Log\) for any lines starting with "Resolved XX groups for...". also look for errors and warnings.

please note that the QVS caches all attempts to resolve groups so it is best to restart it as soon as you've changed any settings.

ps. [AppData] is c:\programdata on vista / 2k8 and c:\documents and settings\all users on xp / 2k3.

Not applicable

Group Authorization to documents

It seems to work after a restart of the server.

Thanks for your input!

/HP

Community Browser