Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Hyperlink in chart not working with firefox

Has anyone run into this issue?

I have a chart with records, and as one of the expressions I have a link.

When I run the dashboard from Internet Explorer (Full Browser Mode) it opens the link (PDF File on our server) in a new tab.

When I run the dashboard from Internet Explorer (Internet Explorer Plugin Mode) it opens the link (PDF File on our server) in Adobe.

However when I open the dashboard in Firefox (Full Browser Mode) the link opens a new tab, but it remains blank. Edit: it seems to be adding our qlikview server location and a string of  letters before the path of the link. When I remove this section the document opens.

Edit: When using Google Chrome when the link is clicked nothing happens. If the mouse is hovered over the link, then the correct path is displayed in the bottom of the screen.

Edit Edit: When Firefox opens the blank tab, the correct path is listed, however for some reason qlikview(or firefox) is adding this to the beginning of the path:

http://ourservername/QvAJAXZfc/

so the path in the browser now says:

http://ourservername/QvAJAXZfc/\\pathtofilelocation.pdf

Labels (1)
8 Replies
Not applicable

Re: Hyperlink in chart not working with firefox

Has no one else seen this issue?

fabienmd
Contributor

Re: Hyperlink in chart not working with firefox

Hi, I have the same issue, did you find a way to make it work in Firefox ?

Is there someone else with an answer to that problem ?

Thank you

Employee
Employee

Re: Hyperlink in chart not working with firefox

Can you post a sample qvw with what you are trying to do in it?

Bill

fabienmd
Contributor

Re: Hyperlink in chart not working with firefox

Thank you for your answer.

I just have a button which open a word file (.doc), using "open an url" => " ='\\MyServer\Source\MyDoc.doc' "

In IE, it works fine it open a link like this http://MyServer/Source/MyDoc.doc

In Firefox, the link opened is like this http://MyServer/QvAJAXZfc/MyServer/Source/MyDoc.doc, which doesn't work.

Not applicable

Re: Hyperlink in chart not working with firefox

Hi there,

i do have the same problem

The IE is working fine but Firefox adds an extra server name and QVAJAXZfc :-(

Is there no answer yet?

Thanks for any help!

padmaja_gade
New Contributor III

Re: Hyperlink in chart not working with firefox

Hi there!

Did you find any solution to this issue? I am facing the same problem.  IE works fine but Firefox and Chrome does not.

Thanks,

Padmaja

Employee
Employee

Re: Hyperlink in chart not working with firefox

Hi,

This could be a bug. Please contact support and have them look at the error and the version you are running.

Bill

fabienmd
Contributor

Re: Hyperlink in chart not working with firefox


Qlik said to us that it was in fact a bug, but they won't be correcting it in a near future from what I understood.