Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Internet Explorer Plugin not working

Hello,

We are having an issue with some end users as they are not being able to use Internet Explorer Plugin.

They can install it and open QV documents selecting IE plugin option (see picture below) but when they try to create a new object or modify an existing one by right clicking and selecting any of the available options, nothing shows up and IE crashes.

a.PNG.png

They have already added QV IP to trusted sites in IE


b.PNG.png


Some of them can use the plugin using different IE versions without any problem so it seems something related to IE setup.

QlikView Server version: 11.0.11440.0

Any advice on that?

Thanks a lot in advance,

Iago.

Labels (2)
1 Solution

Accepted Solutions
gno
Valued Contributor II

Re: Internet Explorer Plugin not working

Lago,

On above you mention that you are testing it with IE10, not that V11.00 SR2 (11.00.11440) only supports up to IE9. Have you try with IE8 or IE9?

Gio

11 Replies
mls
Contributor

Re: Internet Explorer Plugin not working

This is quite an old version of 11. Could you try with the latest plugin (11.20 SR7) on one of the client machines? It might be a problem that has already been solved.

Re: Internet Explorer Plugin not working

Hi,

Couple of things

1) This is very old version of Qlik, Consider upgrading it.

2) Make sure the user uses same IE pluggin as that of your server version.

3) As it is working for some users I suggest to check their IE version and install the same for those users you have an issue with.

Let me know if that worked.

Regards

ASHFAQ

Not applicable

Re: Internet Explorer Plugin not working

Thanks a lot for your answers. We will consider upgrading soon but not at the moment.

I am checking two different PCs with same version of IE (IE 10)

One of them is able to install and use the plugin and this is showing up in Manage Add-ons

b.PNG.png

Whereas in the other one, installation of plugin was successful but when I go to Manage Add-ons, the extentions is not there:


a.PNG.png


Any idea why?

Re: Internet Explorer Plugin not working

This cause this issue.

For the one with issue. I would suggest you to go to control panel and remove pluggin.

This time install with admin privileges.

make sure to restart this machine once.

Let me know if that worked.

Regards

ASHFAQ

mls
Contributor

Re: Internet Explorer Plugin not working

is it there if you select "All add-ons" below to the left? (Instead of "Currently loaded add-ons)

Not applicable

Re: Internet Explorer Plugin not working

I have removed the plugin, install it again with admin privileges and restart the machine but still not working.

I cannot even see the plugin in "All add-ons"

a.PNG.png

Any other idea why this is happening?

Thanks a lot for your help.

mls
Contributor

Re: Internet Explorer Plugin not working

It could be that it is not registered which could happen if the installer didn't have enough privileges.

You could try running a command prompt as administrator and then registering the OCX manually. First find where QlikOCX.ocx is located on disk, and then run

If on 32bit OS:

regsvr32 "C:\Program Files\QlikView\QvPlugin\QlikOCX.ocx"

Or, if on 64 bit OS:

"C:\Windows\SysWOW64\regsvr32.exe" "C:\Program Files (x86)\QlikView\QvPlugin\QlikOCX.ocx"

Not applicable

Re: Internet Explorer Plugin not working

Hello Magnus,

I just tried your solution but unfortunately it didn´t work. I was able to run the command but plugin still not available in Add-ons and crashing IE when I try to use it in QlikView

a.PNG.png

mls
Contributor

Re: Internet Explorer Plugin not working

Hi Iago,

ok, that's a pity. It might be worth just doing a quick test upgrading to the latest plugin on the machine which has the problem just in case it is something which has been fixed already.

Could also be a compatibility issue with the other add-ons. See if there are any add-ons on the bad machine which are not on the working machine and if so, disable them temporarily.
Regards,
Magnus