Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Lost connection to server

Hello experts,

very often the web browser shows me the message in object even if the session remains inactive for fews seconds.

what it means ?

How can I set this timeout ?

Many Thanks.

Best regards

21 Replies
vgutkovsky
Honored Contributor II

Lost connection to server

Check the settings in the Peformance tab located in QEMC --> System --> QlikView Servers. Specifically, see the "Sessions" section on that tab.

Regards,

Not applicable

Lost connection to server

below the server session parameters settings:

Maximum number of concurrent session:5000

Possible session timeout:
(server may terminate inacive sessions
and re-use slot if needed for other users) : 1800 seconds

Maximum inactive session time:
(0 means no limit): 1800 seconds

Maximum total session time:
(0 means no limit): 0 seconds

I get the "Lost connection to server" message only on some clients very often.

what I'd check on these pc ?

vgutkovsky
Honored Contributor II

Lost connection to server

That doesn't sound like a timeout issue to me, but rather a network issue. Make sure port 4747 is open for that client (both directions). Try adding the server into the Trusted Sites list of the client's IE.

Regards,

Not applicable

Lost connection to server

Vlad,

I have the same error, but I´m connecting directly from server to server. No network is involved, so I think that isn´t necessary the port configuration. The document opens, but when I click another sheet, the message "Lost Connection..." appears and the "You can´t access this document.".

vgutkovsky
Honored Contributor II

Lost connection to server

Can you clarify what you mean by "server to server"?

Regards,

Not applicable

Lost connection to server

Local connection. I´m using the browser from the server.

Regards,

Lost connection to server

Is the document being reloaded by a scheduled reload?

-Rob

Not applicable

Lost connection to server

No. Is there any configuration to do in Qlikview Web Server to open AJAX documents in Anonymous? The log indicates that the access is in anonymous way, but I´m connected with a valid user, with a CAL assigned.

vgutkovsky
Honored Contributor II

Lost connection to server

Try disabling anonymous access in QEMC --> Security. If you are using IIS, also disable anonymous access (and enable Windows Authentication) on all virtual directories except Scripts. In Scripts, make sure both anonymous and Windows authentication is enabled. If you are allowing Anonymous access, that will be the first authentication method used in some cases, and that's why you won't authenticate as the current Windows user.

AJAX by default always authenticates using anonymous authentication. To change this, open QEMC --> System --> QlikView Web Servers --> AJAX tab. There is a checkbox there "Always anonymous." If you are using IIS, I think you will then also need to make sure you are allowing anonymous authentication on the QvAJAXZfc virtual directory (not sure about this).

Regards,

Community Browser