Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

ali_hijazi
Honored Contributor

MaxReceivedMessageSize

Hello

Got a task that distributes a document it was working properly until I added a new filed to the selected fields in the reduction tab:

I started getting the following error:

3/2/2015 11:21:32.0141064 Error Exception=System.ServiceModel.CommunicationException: DSC did not respond to request.
Last exception (for http://altqlikview:4730/DSC/Service): The maximum message size quota for incoming messages (262144) has been exceeded. To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element. ---> System.ServiceModel.CommunicationException: The maximum message size quota for incoming messages (262144) has been exceeded. To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element. ---> System.ServiceModel.QuotaExceededException: The maximum message size quota for incoming messages (262144) has been exceeded. To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element.

I went to C:\Program Files\QlikView\Management Service

and edited teh QVManagementService.exe.config file and increased the number 262144 to 2621440 (of course after stopping the management service)

but I still get the same error

Please advise

I can walk on water when it freezes
8 Replies
Employee
Employee

Re: MaxReceivedMessageSize

Ali,

Instead can you just double the default number from 26144 to 52288? Make sure when you open the .config file, open it with notepad but "run as administrator", and like you know after the change, restart the QMC service.

Gio

Giuseppe Novello
Principal Technical Support Engineer @ Qlik
ali_hijazi
Honored Contributor

Re: MaxReceivedMessageSize

I added a zero to the right so not multiplying it by 2 but rather by 10

but still the error message refers to the old number 262144 and not 2621440

I can walk on water when it freezes
Employee
Employee

Re: MaxReceivedMessageSize

Ali,

Well, the reason I express this bc thats the magic number that has fix other people with same issue. if you believe it is unreasonable you are more than welcome to wait for another best answer.

Gio

Giuseppe Novello
Principal Technical Support Engineer @ Qlik
Employee
Employee

Re: MaxReceivedMessageSize

I would not add a zero. Giuseppe is correct that doubling it works best most of the time.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
ali_hijazi
Honored Contributor

Re: MaxReceivedMessageSize

I doubled the number

but I still get the error saying that 262144 has been exceeded

I can walk on water when it freezes
ali_hijazi
Honored Contributor

Re: MaxReceivedMessageSize

this configuration setting is only available for the Management Service

shall I add it to other services' config files (the MaxReceivedMessageSize)

please advise

I can walk on water when it freezes
Employee
Employee

Re: MaxReceivedMessageSize

No, this issue only affects the QMC.

You can try recreating the task to see if something is corrupted with the other task.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
sgrice
Contributor II

Re: MaxReceivedMessageSize

There is a hard coded timeout of 20 seconds for the workorder to be completed. If a customer has a lot of old disabled tasks, or has had to lower their Chunk Size in the past, this can cause the workorder communication to take longer than 20 Seconds. It will attempt to start over and continue in this loop. This will cause the QMC to list tasks as “Unrunnable” , the QDS status to show as “Cluster Down” and errors in the QMS logs regarding “Quotasize errors.”

In order to resolve the issue, it may be necessary to increase the "MaxReceivedMessageSize" setting found in C:\Program Files\QlikView\Management Service\QVManagementService.exe.config. The issue may also be resolved by adjusting the Chunk Size to a higher value, or cleaning out old disabled tasks, in order to reduce the time the Workorder takes to complete.

In some cases it may be necessary to decrease the chunk size!

Further information can be found in Task Won't Run in Publisher - Adjust Chunk Size as well as QDS Distribution Task Fails With Error "The maximum message size quota for incoming messages (262144) has been exceeded.

Lik to Orig Post

QMC displays “Cluster down” and the status of all tasks is listed as “Unrunnable” - Public Knowledge...

Community Browser