Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

erjohnso
Contributor

Multiple Distribution Service IDs in QVPR files?

We recently migrated our QlikView (12.02) environment to a new server and now experiencing an issue in QMC where our tasks and source folders are gone and when going to QMC > System > Setup > QVS@myservername, I get the following error:

ERROR: Failed to load because item with ID 64xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx does not exist. Make sure that QVS is available with the correct credentials.

Licenses are good, service ID on the server has admin rights. So after scouring the community and help pages, I found that a few of the QVPR files have distribution service IDs that do not match the correct ID (64xxx...). I stopped all services and corrected the IDs to match but the following files roll the ID back to the wrong IDs (from test server and eval license):

DirectoryResource

MailTemplate

QDSCluster

SourceDocumentFolderResource

The only solution I found was to uninstall and reinstall QVS...but hoping there is a simpler solution that I am missing that will prevent these files from overwriting the QDS ID into the xml code.

Thanks in advance!

1 Solution

Accepted Solutions
erjohnso
Contributor

Re: Multiple Distribution Service IDs in QVPR files?

FYI, I found that the configuration file in the C:\ProgramData\QlikTech\DistributionService folder also had the wrong service ID so after stopping services, changing the ID and restarting services, all is back to normal. All tasks returned to QMC like magic!

1 Reply
erjohnso
Contributor

Re: Multiple Distribution Service IDs in QVPR files?

FYI, I found that the configuration file in the C:\ProgramData\QlikTech\DistributionService folder also had the wrong service ID so after stopping services, changing the ID and restarting services, all is back to normal. All tasks returned to QMC like magic!

Community Browser