Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Contributor III

No user CAL

Hello Everyone,

I hope somebody can help me out with this: I am trying to connect to the server using the iPhone Client and it shows the list of available documents, but when I try to open one, it shows the following error:

error loading image

Our server has licences available so why is it not letting me in? Any ideas?

Any help is greatly appreciated.


Tags (2)
4 Replies
Honored Contributor II

No user CAL

This seems to me to be an authentication problem. Specifically, QVS issues Named User CALs based on Windows login information. If you have the default NTFS authorization enabled, when a user accesses a document from a Windows workstation, it will pull the NT identity that he is logged in under and issue that user a CAL. When accessing a document from an IPod, you do not have an NT login identity so QVS can't issue a Named User CAL.

Therefore, if you have a significant amount of users using IPods to connect to files, it might be a good idea to switch from NTFS authorization to DMS. Under DMS, you can issue Qlikview-proprietary usernames for people using IPods and keep domain accounts for people accessing documents from workstations.

Not applicable

No user CAL

Hi guys

I am have the same problem and i do to say Vlad but not worked,

mike.garcia you could solve this problem??

tell us

Contributor III

No user CAL


Thank you Vlad for your suggestion. That allowed to narrow our search for solutions and finally got the iPhone up and running. What we did is to configure the following options (which are found in this page: http://community.qlik.com/wikis/qlikview-wiki/iphone-document-access.aspx):

Authenticated Access Using NTFS Authorization

  • QlikView Server Authorization: "NTFS"
  • QlikView Server Authentication: "Prohibit Anonymous"
  • QlikView Web Server Ajax access: "AlwaysAnonymous" = deselected

On the File Server the user in question needs to be added to the document.

First, we solved the problem by setting the Identification (Under System / Licenses / CALs / General) to Machine name, but we didn't know why. So after our research, we could change that to username because that was generating anonymous licenses for every session until we ran out of licenses.

Hope that helps you dtorcates.



Not applicable

No user CAL

Smile Ohh yes Work !!!!

Thanks a lot.



Community Browser