Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Problem when changing Management Service logon

Hi,

I want to change the Account service on a V11 SR1 Server on a IIS single machine).

(my new service account is a local administrator, is a member of the Active Directory, and is a member of the local group QlikView Administrators).

If I change the service account for every other QlikView Service, all is okay.

But when I change the service account for the QlikView Management Service, (I restart the service, and even then server), the QMC display that 2 or more services are down (while services are running). If I set back the old service account for this service, all is ok ??

It isn't the first time I've this problem.

I'd like to correct without reinstalling the server.

Is anyone have an idea ?

Best regards

7 Replies
MVP
MVP

Re: Problem when changing Management Service logon

Hi,

That should work if you first stop all services, then change the logon account, then you start services again. Note that permissions in local groups are applied when the user logs on, so if you have not done it yet, just log on to the QlikView Server with the new account, then log off, then make the changes as mentioned.

Hope that helps.

Miguel

vgutkovsky
Honored Contributor II

Re: Problem when changing Management Service logon

Miguel, I hadn't heard about that trick with logging on as the service account to finalize permissions. Thanks for the tip, will keep it in mind for the future.

Vlad

MVP
MVP

Re: Problem when changing Management Service logon

You're welcome!

I don't know how this behaves in different versions of Windows but, so far, local groups require logging on to the computer where the group is, as opposed to domain groups, that spread their membership from the AD in a few seconds.

Regards.

Miguel

Not applicable

Re: Problem when changing Management Service logon

Hi,

I tried your suggestion but it doesn't work

Any other idea ?

Best regards

MVP
MVP

Re: Problem when changing Management Service logon

Hi,

Are you running the Windows Services Console as an administrator (right click, run as administrator)? Even if the user is an administrator the UAC (that should be disabled completely) may avoid some changes in the system...

Hope that helps.

Miguel

Employee
Employee

Re: Problem when changing Management Service logon

Don't forget to change the Application Pool logon also.

Bill

Not applicable

Re: Problem when changing Management Service logon

Thanks all for your answers,

but I still have his problem.

Do you have any other idea ?

I've even tried to uninstall and reinstall QlikView Server (Including erasing the QVPR).

I think I 'm gonna open a ticket on QlikTech Support

Best regards

Community Browser