Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QLikView Web server behind proxy server

We are tyring to simulate using the QLikView Web server behind a firewall by using an IBM HTTP server used as a reverse proxy server.  We are using Mozilla as our browser for all requests.  We are using the Ajax pages on the web server (no Plug-in).  We have been running fiddler traces for the browser requests that are going throgh the proxy server.  We have also run the fiddler traces for requests that are going from the browser to the QLikView Web server directly. 

The web requests that are NOT using the proxy server are working as expected.  These requests are being challenged for a userid/password.  Once the userid/password is validated by the AD that this configured on the web server, the requests are being processed normally.

When we use our proxy server, we are NOT being challenged for a userid/password.  The default index.html page is loaded into the browser.  The index.html tries to perform a POST with https://<our proxy server>/QvAJAXZfc/AccessPoint.aspx?mark=&platform=browser.MSIE%207.0&dpi=96.  This request is never returned to the browser and eventually times out. 

I have compared the 2 fiddler traces and it looks like failing proxy server requests do not contain the session cookie for the browser.  I am trying to get the proxy server logs to see the proxy server is removing the session cookie information.

Can somebody please tell me if I need to configure something in the QLikView Web server to allow the requests to flow thought a proxy server?

Working header:

POST http://<our qlik view web server>/QvAJAXZfc/AccessPoint.aspx?mark=&platform=browser.MSIE%207.0&dpi=96 HTTP/1.1

Accept: */*

Accept-Language: en-us

Referer: http://relgtddas002/qlikview/index.htm

UA-CPU: x86

Accept-Encoding: gzip, deflate

User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; InfoPath.1; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8)

Host: relgtddas002

Content-Length: 190

Connection: Keep-Alive

Pragma: no-cache

Cookie: Login=True

Failing Header (no session cookie):

POST https://<proxy server>/QvAJAXZfc/AccessPoint.aspx?mark=&platform=browser.MSIE%207.0&dpi=96 HTTP/1.1

Accept: */*

Accept-Language: en-us

Referer: http://relgtddas002/qlikview/index.htm

UA-CPU: x86

Accept-Encoding: gzip, deflate

User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; InfoPath.1; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8)

Host: relgtddas002

Content-Length: 165

Connection: Keep-Alive

Pragma: no-cache

Cookie: Login=True; AccessPointSession=6e3d1aa3-1b91-8666-08ba-902bfe3cf443

2 Replies
Not applicable

Re: QLikView Web server behind proxy server

We have similar issue...

request made directly the QV server (IIS) works

request made via reverse proxy server fails

can someone please reply to above post...

Employee
Employee

Re: QLikView Web server behind proxy server

I played with this at one point using Microsoft ISA server. There was a setting I had to change to allow the login box to past through the proxy( it had to do with pass through  authentication). Once I did this everything worked as expected.

Bill