Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

QMC Reload Now not working

We're experiencing a server-wide issue where no users can reload a QVW using the QMC. The Status tab shows 0 jobs running and when you go to a document (we have tried 5+ different apps) and hit Reload Now, nothing seems to happen. The log file is not updated and the job never hits the Status tab.

We tried restarting the server yesterday, but the issues are persistent. Multiple users are experiencing the same issue.

Thoughts?

Tags (2)
4 Replies
Not applicable

Re: QMC Reload Now not working

The TaskLog for the job showed it completed successfully, but then had the following error at the end:

12/10/2014 12:04:08.0000410ErrorException=System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: An item with the same key has already been added.

   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)

   at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)

   at QDSMain.TaskStore.AddRange(IEnumerable`1 tasks)

   at QDSMain.Task.AbstractTask.NotifyTriggers(ILogBucket logBucket, TaskResult taskResult)

   at QDSMain.Task.AbstractTask.TaskCompletedCleanup(ILogBucket logBucket, TaskResult taskResult)

   at QDSMain.Task.AbstractTask.TaskThread(ILogBucket logBucket, TaskResult taskResult)

   --- End of inner exception stack trace ---

   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)

   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)

   at System.Delegate.DynamicInvokeImpl(Object[] args)

   at SolutionGlobal.ThreadPool.ThreadPoolJob.Execute()

After we rebooted the server it shows a job was running on the Status tab, but when I right-clicked on it I got the following message:

Snip.PNG

There was an inuse file in the Log folder prior to rebooting the server, but it is not there any longer.

bibopipo
Contributor II

Re: QMC Reload Now not working

Hi,

Try to delete and create again the task. Usually it works.

Not applicable

Re: QMC Reload Now not working

Are you getting the same error when you create a new job for a new application or does it only happen on legacy jobs/applications? 

Not applicable

Re: QMC Reload Now not working

For those experiencing this error, I found this post helpful.

https://www.qlikcommunity.com/thread/112357

Particularly, the solution that Simen Kind Gulbrandsen gives towards the end of the thread.

Community Browser