Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QMC: empty status list after mount a new folder

Every time that I mount a new folder in the QlikView Management Console, the list of the Status tab appears empty. I don't see any task schedule (however they run fine) and when I reload a task manually, it runs but doesn't trigger the next task to run.

Usually, to solve this problem, I need to check if there is a file in the TaskResults folder that references a task/document that doesn't exists any more (in my setup: C:\Documents and Settings\All Users\Application Data\QlikTech\Publisher\Qlikview Distribution Service\TaskResults).

It seems that QlikView has problems with the cleanup when documents appear or disappear.

Anybody has similar troubles? Solutions or workarounds?

UPDATE: this time, it was related with 2 new schedules. I removed the schedules and the status list is back again. Definitely, QMC has problems refreshing with task/document updates.



Thanks in advance.

6 Replies
Not applicable

QMC: empty status list after mount a new folder

I use QEMC instead of QMC and never seen this kind of problems, bye.

Not applicable

QMC: empty status list after mount a new folder

Hi All! I use QEMC exactly, but the exactly same issue with empty status page occurs. Everything dissapears even if I change a single reload option. Moreover, the reloads DO NOT run at all. This morning I saw that the last reload ran 4 days ago (this is the latest log). Can you provide a workaround or at least a possible reason why this may happen? I use QVS 9 SR 3.

Regards,

Sergey

Not applicable

QMC: empty status list after mount a new folder

A workaround that is working for me (at least up to now) is first remove the folder; then, make the changes in the files; add the folder again and reschedule all the tasks related with this application.

Until we have a fix, it seems to be working.

mmisfeldt
New Contributor II

QMC: empty status list after mount a new folder

Normal 0 false false false EN-US X-NONE X-NONE

I had this same problem.

To fix it:
1 - Remove all scheduled tasks

2 - Edit the file "StandardScheduleListClustered.xml" in C:\Documents and Settings\All Users\Application Data\QlikTech\Publisher\Qlikview Distribution Service\



to:

<? Xml version ="1.0"encoding = "utf-8"?><Root />



3 - Restart all services QVS;

4 - Reconfigure the tasks.

After completing the above steps, the tasks are already in the list of status.



Regards,

Melissa Misfeldt

Not applicable

QMC: empty status list after mount a new folder

Mellisa,

Doing that you lost all your configuration, right?

dd. //

colinh
Contributor II

QMC: empty status list after mount a new folder

I've had repeated problems with the Reload Scheduler in QlikView 9 at 2 sites, one on SR3 and one on SR5. On both servers making a small change of 10 minutes to even a single task, or adding a new reload task, resulted in a number of the tasks disappearing from the Status page and not reloading when scheduled.

Searching the forums brought me to this post as well as

http://community.qlik.com/forums/t/31281.aspx

http://community.qlik.com/forums/t/26746.aspx

http://community.qlik.com/forums/t/28415.aspx

But none of these had a simple answer.

I've now found a solution that works for me. If you make changes to the reload schedule and certain tasks disappear from the Status page, go to the QlikView Server Settings tab and click on the Apply button. This seems to refresh the folder(s) and reapply the reload schedule. All tasks should now appear as expected on the Status page.

Hopefully this is useful to anyone having similar problems.



Community Browser