Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Highlighted
googel84
Contributor III

QMS backend web service over HTTP rather than over HTTPS

Hi, I noticed that our production environment exposes the QMS backend web service over HTTPS, but I would like to reach it over HTTP, just like it is on the development environment.

How can I do that? I can't find any point in the QMC where this setting is editable.


Many thanks.

Tags (2)
5 Replies
Support
Support

Re: QMS backend web service over HTTP rather than over HTTPS

Hi,

You can check this and see if it is set. Below is how you would set it to use SSL.

  1. Goto C:\Program Files\QlikView\Management Service\QVManagementService.exe.config then set the value to true as shown in the following tag.
    <add key="UseHTTPS" value="True"/>
  2. Next go to section <!-- ****** QlikView Management Service - FRONTEND ****** --> and set the value to 443 in the following tag.
    <add key="QMSFrontendWebServicePort" value="443"/>
  3. Restart Webserver service & test by typing https://:443/qmc or https://localhost/qmc/

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
googel84
Contributor III

Re: QMS backend web service over HTTP rather than over HTTPS

Thanks Bill, but I would rather like to use HTTP instead of HTTPS.

The strange thing, though, is that the QVManagementService.exe.config file actually seems to to be set this way but the truth is that if I type http://localhost:4799/QMS/Service, the request timeouts... if I, instead, use https, it works.

Could it have to deal with the fact that who installed and configured the system was forced to use certificates to allow communication between services (<add key="UseWinAuthentication" value="false"/>)?


If this is the case, I think I should better adapt the application to this specific setting but, to be honest, I would not know what to do.

Have you got any experience concerning this C# task?

Support
Support

Re: QMS backend web service over HTTP rather than over HTTPS

Hi,

OK, I guess you did not understand my post, so let me do it again. If you don't want SSL change the below items,

  1. Goto C:\Program Files\QlikView\Management Service\QVManagementService.exe.config then set the value to true as shown in the following tag.
    <add key="UseHTTPS" value="False"/>
  2. Next go to section <!-- ****** QlikView Management Service - FRONTEND ****** --> and set the value to 80 in the following tag.
    <add key="QMSFrontendWebServicePort" value="80>
  3. Restart Webserver service & test by typing  http://localhost/qmc/

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
gdevarashettyhf
New Contributor III

Re: QMS backend web service over HTTP rather than over HTTPS

Hey Bill, I am having the same issue. I have made changes as you suggested. When access http://localhost/qmc/ it gives 404 error.

My situation is I need to access QMS Service using HTTP. Right now it works with HTTPS.

i.e. https://sv-qvpub1q:4799/QMS/Service works

but I need

http://sv-qvpub1q:4799/QMS/Service to WORK instead.

 

Support
Support

Re: QMS backend web service over HTTP rather than over HTTPS

Hello,

The QlikView QMC, by default, is accessible using HTTP.  HTTPS needs to be manually set up.

The default URL for the QMC out of the box is http://yourhost:4780/qmc/

If you were accessing this using https://localhost/qmc/, then changes must have been made to the system to support this. These changes would have been done as Bill documented it for you (more details here (kb 000003889).

If you revert this back to default:

<!-- Use HTTPS instead of HTTP for SSL-encrypted communication. You must configure a certificate for this to work -->
<add key="UseHTTPS" value="False"/>
<!-- The port that the QMS frontend listens to (if not specified, port 4780 will be used) -->

<add key="QMSFrontendWebServicePort" value="4780"></add>

... then you will be back to default behaviour. But you'll be using port 4780, as intended. Not port 80. But you'll be using HTTP, not HTTS.

This is also the URL that is important to you, and the one you use when accessing the front end of the QMC.

This one, on the other hand: https://yourhost:4799/QMS/Service is not meant for end-user access, but used between the services. If you have configured Certificate Trust between the service, rather than Windows Administrator Group, then this will automatically be switched to https and we recommend to not change it. 

To help users find verified answers, please don't forget to mark a correct resolution or answer to your problem or question as correct.
For more Qlik Knowledge content, check out our Support Knowledgebase