Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

googel84
Contributor III

QMS backend web service over HTTP rather than over HTTPS

Hi, I noticed that our production environment exposes the QMS backend web service over HTTPS, but I would like to reach it over HTTP, just like it is on the development environment.

How can I do that? I can't find any point in the QMC where this setting is editable.


Many thanks.

Tags (2)
3 Replies
Employee
Employee

Re: QMS backend web service over HTTP rather than over HTTPS

Hi,

You can check this and see if it is set. Below is how you would set it to use SSL.

  1. Goto C:\Program Files\QlikView\Management Service\QVManagementService.exe.config then set the value to true as shown in the following tag.
    <add key="UseHTTPS" value="True"/>
  2. Next go to section <!-- ****** QlikView Management Service - FRONTEND ****** --> and set the value to 443 in the following tag.
    <add key="QMSFrontendWebServicePort" value="443"/>
  3. Restart Webserver service & test by typing https://:443/qmc or https://localhost/qmc/

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
googel84
Contributor III

Re: QMS backend web service over HTTP rather than over HTTPS

Thanks Bill, but I would rather like to use HTTP instead of HTTPS.

The strange thing, though, is that the QVManagementService.exe.config file actually seems to to be set this way but the truth is that if I type http://localhost:4799/QMS/Service, the request timeouts... if I, instead, use https, it works.

Could it have to deal with the fact that who installed and configured the system was forced to use certificates to allow communication between services (<add key="UseWinAuthentication" value="false"/>)?


If this is the case, I think I should better adapt the application to this specific setting but, to be honest, I would not know what to do.

Have you got any experience concerning this C# task?

Employee
Employee

Re: QMS backend web service over HTTP rather than over HTTPS

Hi,

OK, I guess you did not understand my post, so let me do it again. If you don't want SSL change the below items,

  1. Goto C:\Program Files\QlikView\Management Service\QVManagementService.exe.config then set the value to true as shown in the following tag.
    <add key="UseHTTPS" value="False"/>
  2. Next go to section <!-- ****** QlikView Management Service - FRONTEND ****** --> and set the value to 80 in the following tag.
    <add key="QMSFrontendWebServicePort" value="80>
  3. Restart Webserver service & test by typing  http://localhost/qmc/

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
Community Browser