Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

kevin_kelly
New Contributor III

QV11 reload randomly failing - Running

We have a QVW that over the past 3 weeks has started failing randomly and it's been a real challenge trying to isolate the exact scenario.  The reload gets to a point in a SQL Select where it's waiting for SQL to fetch the records and just remains in a status of 'Running' in the management console.  We've moved some of the loads to QVD as a way to begin isolating the problem and it will load from an optimized QVD and when it "hangs" it's at the exact same logical point but on a totally different SQL Select.  It ultimately fails after we either kill the reload or times out 24 hours later.  The one common thread is that if it's going to hang it generally happens between 5 and 6 minutes into the reload.  It doesn't seem to matter what SQL Select it's running at that point but it's just hanging out waiting for SQL to return records.  SQL is on a totally different server (same domain) and this has recently just started occurring.  Any thoughts?

Thanks,

Kevin

4 Replies
Not applicable

QV11 reload randomly failing - Running

Check to see that the QVService account has rights to access the server that hosts SQL and has rights to the DB.  It might also make sense to make sure that something else is not running the same thing from somewhere else.  I had a client that had a QVW that was failing to refresh becuase a user had an Access DB open.  The  user would update the DB during the day, as was her duty, but then just leave it open and running all night.  The QVService couldnt get in to refresh records becuase something else was making it "wait in line".  I know that Permission issues will typically crash a task quickly, but you never know.  Also, the log files will sometimes give you some hints.

good luck.

erich_shiino
Honored Contributor

QV11 reload randomly failing - Running

Hi, Kevin

Maybe you and other users are locking tables.

You could try to include a NOLOCK statement in your queries.

You can find more details in the following thread:

http://community.qlik.com/message/83739#83739

Hope this helps,

Erich

jerrysvensson
Valued Contributor II

QV11 reload randomly failing - Running

Are you running MS SQL Server?

There is an explanation of NOLOCK here.

http://www.techrepublic.com/article/using-nolock-and-readpast-table-hints-in-sql-server/6185492

SELECT COUNT(*) FROM SalesHistory WITH(NOLOCK)

does work in QV. Just tried it.

Don't know if it will solve your problem though..

kevin_kelly
New Contributor III

QV11 reload randomly failing - Running

Thank you all for your responses but we've tried/considered all of the above.  We're currently working with level 3 support and no resolution yet.

Community Browser