Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QV9 Server - Macros don't work

Hello,

We are using macros in an application installed on a QV 9 server.

We are using buttons to activate these macros.

They are working fine locally on my PC , but as soon as I install the application on a server (using Ajax Client),

They don't seem to do anything.

I activate the parameters on the server but it still not showing any improvment.

does anyone has an idea ?

Thanks

Philippe

1 Solution

Accepted Solutions
mov
Esteemed Contributor III

QV9 Server - Macros don't work

Not all macros can be used on server. Most work in IE plugin client, but I wouldn't count on them to work in Ajax.

7 Replies
jsn
Honored Contributor

QV9 Server - Macros don't work

Could you provide a little more information on what the macros do? Example code / document would be helpful. Does it run using the plugin? It could be that you're using certain things that are not available in Client/Server as opposed to stand alone document (More info in QVS ref manual regarding macros).

Not applicable

QV9 Server - Macros don't work

The does a dynamic update ... but if i put some traces I can see that the macro does not start at all.

mov
Esteemed Contributor III

QV9 Server - Macros don't work

Not all macros can be used on server. Most work in IE plugin client, but I wouldn't count on them to work in Ajax.

Not applicable

QV9 Server - Macros don't work

Thanks michael,

THe problem was on the serve side. Qliktech R&D are working on it. Seems to be a bug related to QV9.

Philippe

Not applicable

QV9 Server - Macros don't work

What bug are they specifically working on? Server side macros do not run from IE and Ajax clients in QV9? I've been trying to resolve the same issue. Please advise.

Not applicable

QV9 Server - Macros don't work

i am also having this issue.

very simple macro's which simply change document variable in order to enable items on screen.

is there any more information on this ? i have tried using IE Client, AJAX and Java Client.

Thanks

Chris

Not applicable

QV9 Server - Macros don't work

Hi

I am also facing the same issue macors are not working in any of the clients Java,Ajax and the IE Plugin is by default disabled for me. I am not sure how to enable the IE Plugin. Any one can help me in enabling IE Plugin and how to run the macros.

Regards,

xxxx