Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

QVS service showing off duty and no server error on webpage

Dear All,

Since last few days all user's  getting error while accessing qlikview from IEor chrome.

and i noticed that QVS service showing OFF duty and won't able to start it.

Can anyone please suggest me the best sollution for this issue.

Thanks in advance.

Error1.pngerror2.png

9 Replies

Re: QVS service showing off duty and no server error on webpage

Relicense your server. QVS hasn't been properly licensed, so no party for you (or your end-users)

Open QMC, select System->Setup->Licenses->QlikView Server->QlikView Server License, enter Serial, ControlNo, Name and Company and click Apply license.

Re: QVS service showing off duty and no server error on webpage

Sorry, I forgot about this:

Make sure that your license isn't being used by another QVS installation. You cannot run two QVS's using the same license. They will both go off-duty.

manojkulkarni
Valued Contributor II

Re: QVS service showing off duty and no server error on webpage

Make sure that same license isn't being used by another QVS installation. You cannot run two QVS's using the same license. One Server will go down. It will show message like off duty

MVP
MVP

Re: QVS service showing off duty and no server error on webpage

Hi,

Check whether QVS Service is up in Services.msc.

OR

If the same license is used in multiple servers you will get this error.

Regards,

Jagan.

Not applicable

Re: QVS service showing off duty and no server error on webpage

Dear All,

Thank for your response.

How can i detect that some other server also using the same license?.

Because in QVS detector it shows only single entity.

MVP
MVP

Re: QVS service showing off duty and no server error on webpage

Hi Prakash,

Check this link, you can use QVSDetector which comes with PowerTools to identify where you are using the license.

Download PowerTools and run the QVSDetector and see if it show other servers on your network with the same license number.


Re: Mayor problem - QVS "off_duty" - plz help


Regards,

Jagan.

Not applicable

Re: QVS service showing off duty and no server error on webpage

Hi Jagan,

As informed i had already checked  with QVSdetector,but it shows only one server.

Regards,

Prakash

MVP
MVP

Re: QVS service showing off duty and no server error on webpage

Hi,

Check whether the service is up and running?  Also if possible try to restart the server machine sometimes this will fix. 

Also check whether your license is not expired.

Regards,

Jagan.

Re: QVS service showing off duty and no server error on webpage

The QVS that is going off-duty may write a message about this condition in the QVS Events Log. Not sure about whether there is any info about the other QlikView server, but you can check. In QMC, you may have to switch Event Log Verbosity to High first.

Event logs are located in C:\ProgramData\QlikTech\QlikViewServer

You're sure that no old QlikView server is still running in your network? If you're using a VM, there is no copy running at the same time? When was your server last restarted? Did the problems start at that moment? If so, then that's proof that some other server is using the same license. Another reason could be that your QlikView Server folder may be corrupted.

Best,

Peter

Community Browser