Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

lvdbrink
New Contributor II

QlikView is deleting old audit files, how do I stop it?

All,

Just over a week ago, our Qlikview publisher server started deleting its "old" audit log files (Session, Event, Audit and Performance). It used to keep all of them indefinetly, but right now anything older than 30 days gets deleted. The ManagementService log (in the folder .\QlikView_Server\ManagementService\Log\) states


"[TIMESTAMP]     Information     Deleting old audit file. Filename="

Now my colleagues did change some settings on the QlikView server itself, but they don't remember touching anything related to this issue or log files in general.

My question is: does anyone have an idea of what configuration file or setting we would have to look at to disable the deletion of old audit files? We would like to keep them indefinetly again. Any help regarding this issue is highly appreciated.

With kind regards,

Lennaert van den Brink

3 Replies
nicander
New Contributor II

Re: QlikView is deleting old audit files, how do I stop it?

Lennaert,

Are you sure you don't have your bat-file running which deletes your 'qvw-log-files-with-timestamp' after 30 days? Maybe this script also accidentally scans the location of the server log files and archives them...

Greetz,

Nicander Badpak

jrepucci15
Contributor

Re: QlikView is deleting old audit files, how do I stop it?

Which version of QV are you running?

lvdbrink
New Contributor II

Re: QlikView is deleting old audit files, how do I stop it?

We are running on 11.2 SR7. We actually found out there is a config file on the server where this value can be adjusted. Thing is we adjusted that config file, but we forgot to restart our QMS service, so it still ran with the old setting. I will try to find out what the exact name of the file was for future reference, but at least our issue has been solved.