Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QlikView on IIS

Hi,

Today I have installed QlikView on a new server. Our requirement is to use IIS instead of QlikView web server. The installation went really smooth. But when I tried to access the access point, I am getting a error 'qva undefined'. The following are details of the installation

1. The server is 64bit with Windows 2008 & IIS7

2. I have installed .Net framework 4 after IIS is installed. (so no need to apply aspnet_regiss)

3. QlikView 10 SR5

4. I am accessing the access point on the same network.

5. When I install QlikView web server on this, everything works perfectly. So I rule out any installation or rights issue.

6. The domain account which is running the QV services is part of administrators group and also QV Administartors

7. The 'Qlikview IIS' application pool is running under 'ApplicationPoolIdentity'.

Please let me know if you need any more information with respect to configuration.

I badly need to resolve this as issue ASAP. Please help me.

Regards,

Murali

1 Solution

Accepted Solutions
Employee
Employee

Re: QlikView on IIS

Another point, the .NET version for QV10 is 3.5, not 4.0.  In Windows 2008 it is added as a "feature".

QV11 however does use .NET 4.0.

7 Replies
Employee
Employee

Re: QlikView on IIS

I see one thing wrong. The Qlikview IIS application pool needs to run under the same account as the services or a users that is a member of the QlikView Administrator group.

Bill

Not applicable

Re: QlikView on IIS

Have a look here. It is for QV11 and IIS 7.5 but it might help.

http://community.qlik.com/message/256293#256293

Not applicable

Re: QlikView on IIS

I have tried to configure he IIS pool with the member of the QlikView administrators group. But still I am getting the same error.

Employee
Employee

Re: QlikView on IIS

Another point, the .NET version for QV10 is 3.5, not 4.0.  In Windows 2008 it is added as a "feature".

QV11 however does use .NET 4.0.

Not applicable

Re: QlikView on IIS

I have removed .net frameworkk 4 from the server and it is working now. But the only issue I have is the QlikView IIS application pool is working under framework 2.0. Is this ok?

Employee
Employee

Re: QlikView on IIS

Awesome.

I know it sounds weird but .NET 3.5 is an extension to .NET 2.0 rather than it being a totally new version.  It is normal for it to still appear as .NET 2.0 in IIS Manager.

Not applicable

Re: QlikView on IIS

To summarise, the two settings that did the trick for me are

1. Changed the application pool credentials to my service account

2. Uninstalled .Net framework 4.0

Thanks a lot for your help to get this resolved quickly.

Community Browser