Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QlikView upgrade 8.5 to 9.0 (x64)

Hi,

We are trying to upgrade our Windows 2003 SP2 x64 server from QVS 8.5 to 9.0. We seem to be running into problems with the .Net version that is required for 9.0.

Asp.Net 2.0 was initially installed on the server, and we upgraded to 3.5 as requested in the QVS Reference Manual. We also installed .Net 3.5 SP1. The QlikView Management Console ran fine but the QlikView Enterprise Management Console kept showing error messages like the one below when we tried to change a setting and then clicked Apply:

error loading image

We then installed .Net 1.1 (as this is apparently not installed by default with x64 Windows 2003 software) and these errors went away. But Microsoft claims .Net 1.1 isn't supported on a x64 server, only x86, and therefore it's reverting all .Net components on our x64 machine to x86 versions of the software.

I'd like to know if you have any advice as to exactly which versions and service packs of .Net we should be running on a x64 Windows 2003 SP2 server to get the best results? And should these be added as web extentions in IIS if we are using IIS as our web server?

any adivce would help

thanks [Smiley Happy]

4 Replies
Not applicable

QlikView upgrade 8.5 to 9.0 (x64)

Hi

.NET version 3.5 is packed in the qlikview 9 installer. Just remove all the components from qlikview 8.5 and then start to install version 9. The first thing that will be installed is .NET 3.5.

!!!!!!! Make sure that IIS is not installed any more, remove it from your computer, or you will get problems installing qlikview server 9.

Best

Ivo

Not applicable

QlikView upgrade 8.5 to 9.0 (x64)

Do we really need to uninstall IIS? This seems a drastic step to upgrade one piece of software

Or is it only removing the websites relating to the old installation?

Not applicable

QlikView upgrade 8.5 to 9.0 (x64)

There is absolutely no need to uninstall IIS to upgrade to 9.0. If you use the builtin web server of qlikview, the only problem would be to check that IIS and QVS are not listening to the same port.

Employee
Employee

QlikView upgrade 8.5 to 9.0 (x64)

IIS isn't required anymore because QlikView users it own WebServer. The ports now that this webserver uses will not interfere with IIS if it is installed. With 2003 and 2008 server the IIS uses port sharing and is aware of the QV webserver. If IIS is installed before QlikView

Community Browser