Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

leandro_abad
New Contributor II

Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

Hi!,

I'm working on an app that use Qlikview Management API. I folowed the steps in this post QlikView Management API - #1 Setting up a Visual Studio project

But when I've compiled the app I have the following error:

Error2The type 'System.Configuration.ConfigurationElement' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.C:\Qlikview\API QV - Leandro\Test\Trigger_1_cadena_2\Trigger_1_cadena_2\ServiceSupport\ServiceKeyBehaviorExtensionElement.cs718Trigger_1_cadena_2

I have no idea what I have to do, any help?

Tags (2)
1 Solution

Accepted Solutions
simondachstr
Valued Contributor III

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

Check the below (found it on stackoverflow):

6l5p4.png

10 Replies
simondachstr
Valued Contributor III

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

Make sure all Service Support files are referenced properly in your project.

leandro_abad
New Contributor II

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

I sure,

Look, in this line I have the error (apparently):

1.png

simondachstr
Valued Contributor III

Re: Qlikview Management API - Problem setting up project  "System.Configuration.ConfigurationElement"

Are you using

using Trigger_1_cadena.QMSAPIService;

using Trigger_1_cadena.ServiceSupport;

in your main.cs file?

leandro_abad
New Contributor II

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

I am using both:

2.png

simondachstr
Valued Contributor III

Re: Qlikview Management API - Problem setting up project  "System.Configuration.ConfigurationElement"

Hmm... can you make sure you're compiling your application in the .net 4 framework..

leandro_abad
New Contributor II

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

Yes, I am sure

simondachstr
Valued Contributor III

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

Check the below (found it on stackoverflow):

6l5p4.png

leandro_abad
New Contributor II

Re: Qlikview Management API - Problem setting up project "System.Configuration.ConfigurationElement"

I find it, where I have to add the reference?

simondachstr
Valued Contributor III

Re: Qlikview Management API - Problem setting up project  "System.Configuration.ConfigurationElement"

To your assembly from my understanding

Community Browser