Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Reload Bug after Update from 10 to 11

Hi,

i recently updated our Qlikview Server from v10 to v11 (no Publisher).

After the update we encountered a bug, where all reload task failed because of a blank within the mounted folder alias name.

This was quickly found and corrected and all our tasks reloaded as usual except one. I can't find any clues why this one suddenly doesn't work after the update and hope you can help me.

The tasks quits after a few seconds returning the error message :

(2012-01-17 09:21:54) Information: Starting task 'MIS-Datamodell/MIS_DataModell.qvw'. Id:703af6bf-695e-4350-b3db-68d876a39037. Triggered by 'ManualStartTrigger'. Id:00000001-0002-0003-0405-0607080a0b0c

(2012-01-17 09:21:54) Information: Entering Task Execution.

(2012-01-17 09:21:54) Information: ClusterID=1

(2012-01-17 09:21:54) Information: QDSID=c5e29d28-ff67-b40f-d037-ec0be07eff23

(2012-01-17 09:21:54) Information: TaskID=703af6bf-695e-4350-b3db-68d876a39037

(2012-01-17 09:21:54) Information: MaxRunTime=06:00:00

(2012-01-17 09:21:54) Information: Max attempts:1

(2012-01-17 09:21:54) Information: Current Attempt=0

(2012-01-17 09:21:54) Information: Task Dependencies are OK

(2012-01-17 09:21:54) Information: Document is marked to be Reloaded with fresh data. Initializing Reload for Distribution.

(2012-01-17 09:21:54) Information: Opening "S:\QLIKVIEW\_PRODUCTION\2_DATAMODELL\MIS_DataModell.qvw"

(2012-01-17 09:21:54) Information: Allocating new QlikView Engine. Current usagecount=2 of 3

(2012-01-17 09:21:54) Information: Max retries:5

(2012-01-17 09:21:54) Information: Attempt:01

(2012-01-17 09:21:54) Information: Allocated QlikView Engine successfully. Current usagecount=2 of 3, Ticket=56

(2012-01-17 09:21:54) Information: Loading document "S:\QLIKVIEW\_PRODUCTION\2_DATAMODELL\MIS_DataModell.qvw" (7754.96 Mb)

(2012-01-17 09:21:55) Information: Loading. LoadTime=00:00:00.9999552

(2012-01-17 09:21:57) Information: Loading. LoadTime=00:00:02.9998656

(2012-01-17 09:22:00) Error: Document open call failed. The document might require username and password.

(2012-01-17 09:22:00) Information: Attempted to load the document without data.

(2012-01-17 09:22:00) Error: The document failed to open.

(2012-01-17 09:22:00) Information: Closed the QlikView Engine successfully. ProcessID=4692

(2012-01-17 09:22:00) Error: Document could not be opened

(2012-01-17 09:22:00) Information: Closed the QlikView Engine successfully. ProcessID=4692

(2012-01-17 09:22:00) Information: Failed to check in document: S:\QLIKVIEW\_PRODUCTION\2_DATAMODELL\MIS_DataModell.qvw

(2012-01-17 09:22:00) Error: The task "MIS-Datamodell/MIS_DataModell.qvw" failed. Exception:

(2012-01-17 09:22:00) Error: QDSMain.Exceptions.DistributionFailedException: Distribute failed with errors to follow. ---> QDSMain.Exceptions.ReloadFailedException: Reload failed ---> QDSMain.Exceptions.FailedDocumentCheckoutException: Failed to check out document with path: S:\QLIKVIEW\_PRODUCTION\2_DATAMODELL\MIS_DataModell.qvw

(2012-01-17 09:22:00) Error:    at QDSMain.ReloadTask.Reload(String fileName, TaskResult taskResult, String sectionAccessUserName, String sectionAccessPassword, eReloadOptions reloadOption, String variableName, String variableValue, Boolean moniterCpuUsage)

(2012-01-17 09:22:00) Error:    --- End of inner exception stack trace ---

I've already checked the document info in the QEMS and section access box is unchecked with empty username and password fields.

There are several other QVWs located in the same folder scheduled for reload and perfectly working, so I'm rather clueless. The NTFS rights of this file are exactly the same as for the other documents within this folder and the service account has local administrator rights and is granted access to the file

I'd appreciate any hints and tips,

Markus

11 Replies
danielrozental
Honored Contributor II

Reload Bug after Update from 10 to 11

Is the document using section access? you should try adding the user running the QlikView services as a document admin.

Not applicable

Reload Bug after Update from 10 to 11

There is neither in the QEMS nor in the QVW script Section Access activated. And a manual reload within the QV Desktop works flawless.

Do you mean setting the ntfs rights of the document, or how else do i set a document admin ?

danielrozental
Honored Contributor II

Reload Bug after Update from 10 to 11

No, I mean within the section access.

Are you sure there is no hidden script? is the user running the qlikview services the same user you're using to run the reload in the developer?

Not applicable

Reload Bug after Update from 10 to 11

I tried that with no success. Also already added the service account explicitly to the document ntfs, before just the local administrator group was granted.

i checked the script twice, nothing in the script part and a hidden script doesnt exist.

If nothing else helps, i create a new file and copy/paste the scripts. For gods sake it's just the datamodell QVW and not the published application

Reload Bug after Update from 10 to 11

Did the reload generate a document log?

-Rob

Not applicable

Reload Bug after Update from 10 to 11

No, it didn't even delete the latest generated log from the manual reload via desktop. Seems as if the distribution service doesnt even start with the reload.

But i copied the qvw and renamed it to MISTEST and created a new task in the QEMS to exclude the possibilty of a defect task caused by the server upgrade with the same result. So it has to be a problem with the file or corresponding settings / ntfs permissions

After too much frustrating trial and error i created a new file and copy/pasted the script and now it works. I still can't say what caused it, especially when the other 4 QVWs reload without problems. This one was the oldest, initially created under v.8 and further developed and altered while the following server releases. Perhaps it was time for a fresh restart

Thank you for your help !

disqr_rm
Valued Contributor III

Reload Bug after Update from 10 to 11

Anything shows up in Windows log? I noticed that those reloads are just terminated and you feel they weren't even started. I actually had to reconstruct those QVWs, using -prj trick, to be able to get them reloaded again. Try that.

Reload Bug after Update from 10 to 11

I just ran across failed reloads on QV11 when the mounted folder Name contains a space. Is this an already known bug?

-Rob

Not applicable

Re: Reload Bug after Update from 10 to 11

I'm having the exact same problem with a qvw after a change from v10 to v11.

I hope a re-creation of the file is not the only solution!