Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Search Bar Disappearing

We have this strange issue where the 'Search Box' object disappears in our QV documents on AccessPoint.

This is the only object that disappears in our documents. I can log back into the developer copy the search box, delete it, then paste it back and save it. It will then reappear in the QV document it disappeared from earlier. I have also tried recreating the search box completely. This does not seem to make a difference weather I copy or recreate from scratch. The search box will stay on the document for about a day> 24 hours then just disappear. This time variable varies. It disappears for all users using any type of browser (Fire, IE, Chrome). We only use the Ajax client.

We have: QV Server 9.0 SR3 64-bit

Is this a bug? Anyone else experience this or have an remedy?

Thanks for any thoughts or ideas.

10 Replies
MVP
MVP

Search Bar Disappearing

Hello Jacob,

Some strange behavior happened to us using ajax interface as well. In our case it was some textboxes that where automatically minimized. We weren't able to work around that forcing the object to be restored and unchecking "Allow minimize" in the Title tab. We didn't have this problem with the very exact document opened with IE Plugin.

Regards

Not applicable

Search Bar Disappearing

jacob - i have similar issues with certain list boxes prior to SR5. in my case it is a 'layering' issue, combined with a show-hide condition. when you open in the developer copy, if you change the layer of the search object (even if it is already 'top'), then does it reappear? do you also utilize the show/hide condition on this object? i was chasing list boxes around for weeks, until support confirmed it was a bug.

-tammy

Not applicable

Search Bar Disappearing

Good point with the layers. I never thought about this. This object does not employee the show/hide scripts.

I will play with this but still think it sounds buggy.

Not applicable

Search Bar Disappearing

I've seen the same thing. I don't think it's anything to do with the document itself but more with the way the server is handling the data in memory. I haven't been able to consistently reproduce it, but restarting the Qlikview Server invariable resolves the problem for me.

Hopefully upgrading to SR5 will make this go away.

Not applicable

Search Bar Disappearing

Thanks.

I have installed SR5 on the server. I will let you if it disappears again. If not my next attempt is going to restart the QV services daily.

Not applicable

Search Bar Disappearing

Hi everyone,

I'm new in this forum.

I just want to say that the solution " unchecking "Allow minimize" in the Title tab " resolve my problem with the search box.

Thanks a lot!

Regards,

Not applicable

Search Bar Disappearing

Just in addition, I use a macro on open document:

sub DISPLAY_SEARCHOBJECT
on error resume next

for j = 0 to ActiveDocument.NoOfSheets - 1

Objects = ActiveDocument.Sheets(j).GetSheetObjects

for i = lBound(Objects) To uBound(Objects)
set obj = Objects(i)

'For each object that I named with _SO_, I restore the object searhc
if InStr(obj.GetObjectId,"_SO_") then
obj.Restore
end if
next
next

end sub

juleshartley
Valued Contributor

Search Bar Disappearing

Hi,

We are also getting this issue when brining up the 'current selections' box. Sometimes it is there and other times it is not.

When you go into layout and change the layer, even by 1 and then back again, it reappears.

Very frustrating issue that we have not found a satisfactory solution to yet.

Julian

(v.8.5 SR5)

colinh
Contributor II

Search Bar Disappearing

Julian, if I remember right there is a bug in QV 8.5 relating to Current Selections boxes. I know I had problems with them disappearing, and with them not updating to show the selections that I'd made. I think the trick was to make sure the Current Selections box was the last thing you added to the page. Try that and see if it resolves your issue.

This was fixed in version 9.