Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

rido1421
Contributor II

Section Access

Hi There

Something is not working correctly in my section access.

My qlikview user is peterz.

when reloading with the below section access applied.

my user peterz can only see CODE_2   A12.

According to my script, peterz must have access to all CODE_2

it seems as if all other users can also only see A12

for now it seems like kevin can see only A12 CODE_2s linked to COST_CENTRE 2101.

he needs to see all CODE_2s for COST_CENTRE 2101

Your assistance is appreciated.

Section Access;
LOAD * INLINE [
ACCESS, NTNAME, COST_CENTRE, CODE_2
USER,DOMAINNAME\Johna , *, A12
USER, domainname\peterz ,*, *
USER, domainname\paulo ,*,*

USER, domainname\kevinw , 2101,*

 


  ];

Section Application;

1 Solution

Accepted Solutions
Employee
Employee

Re: Section Access

A few things to look at with your example;

- All fields in the section access table must be in UPPER case

- You might want to have at least one ADMIN level user

- * represents all values listed in the reduction field, use a non existing value to represent all data values

Section Access;
LOAD * INLINE [
ACCESS, NTNAME, COST_CENTRE, CODE_2
USER,DOMAINNAME\JOHNA , <ALL VALUES>, A12
USER, DOMAINNAME\PETERZ ,<ALL VALUES>, <ALL VALUES>
USER, DOMAINNAME\PAULO ,<ALL VALUES>,<ALL VALUES>

USER, DOMAINNAME\KEVINW , 2101,<ALL VALUES>

];

Section Application;

Try using USERID instead of NTNAME during your development work. That way you can impersonate your users in an easy way, by entering the USERID in the login credentials.

Section Access;

LOAD * INLINE [
ACCESS, USERID, COST_CENTRE, CODE_2
USER,DOMAINNAME\JOHNA , <ALL VALUES>, A12
USER, DOMAINNAME\PETERZ ,<ALL VALUES>, <ALL VALUES>
USER, DOMAINNAME\PAULO ,<ALL VALUES>,<ALL VALUES>

USER, DOMAINNAME\KEVINW , 2101,<ALL VALUES>

];

Section Application;

29 Replies
rido1421
Contributor II

Re: Section Access

FYI.

I have tried using CAPS

I have “Initial Data Reduction Based on Section Access” and “Strict Exclusion” Ticked.

Re: Section Access

Hi,

Kept it blank to give all acesss

Section Access;
LOAD * INLINE [
ACCESS, NTNAME, COST_CENTRE, CODE_2
USER,DOMAINNAME\Johna , *, A12
USER, domainname\peterz ,,
USER, domainname\paulo ,*,*

USER, domainname\kevinw , 2101,*

 


  ];

Section Application;

Regards

Regards,
Prashant Sangle

Re: Section Access

* represent the value for that which mention in section Access

and to give all access you have kept that field blank.

Regards

Regards,
Prashant Sangle
rido1421
Contributor II

Re: Section Access

Thanks Max Dreamer

I will try it and let you know. just to confirm, when you do a Debug load with section access does it work correctly?

Highlighted

Re: Section Access

Hi,

Depend on data...

Regards

Regards,
Prashant Sangle
Not applicable

Re: Section Access

hi,

keep blank at the place of *. they will see all values.

LOAD * INLINE [
ACCESS, NTNAME, COST_CENTRE, CODE_2

USER, domainname\kevinw , 2101,

  ];

Regards

Vimlesh

rido1421
Contributor II

Re: Section Access

"Failed to Open Document, You do not have access to this document"

This is the Error received... when tryng to access through the access point

rido1421
Contributor II

Re: Section Access

Hi Vimesh

If I remove my User: peterz will it not take away my access to the document completely?

balkumarchandel
Valued Contributor II

Re: Section Access

Generally Debug load with section access does not work .

You need to reload the document save it and close it .

Again open the doc .you should be able to login with correct user ID pwd.