Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

raju_salmon
Contributor

Section access QMC load issue

Hi,

I am receiving below error while loading qvw through qmc where section access implemented (it is working well in local machine).

Error: Document open call failed. The document might require username and password.

Information: Attempted to load the document without data.

Error: The document failed to open. Bad Username and password is the most likely cause of this problem.

I have added server account (user and password) while creating task under reload tab. But still i can see this error and the same account is available in section access table as well.

Can anyone help me what would the issue here?

Thanks,

Raju S

1 Solution

Accepted Solutions

Re: Section access QMC load issue

Whatever you put in the link field isn't that important, as long as you assign ACCESS=ADMIN to the service account. Even strict exclusion, won't have any effect on a reload.

To publish your document with Section Access, you can do one of two things:

  • Either place a QVW without loaded Section Access on your server, and let it be reloaded by the QDS to activate Section Access, or
  • Reload the document on your machine, so that Section Access becomes active immediately before publication but already includes the service account in the SA table.

Also check whether the NTNAME value for the service account includes the domain name (like domain\account) and is spelled correctly.

Best,

Peter

9 Replies

Re: Section access QMC load issue

On a QlikView Server, the service account running the QlikView services is the one trying to open and reload your document. Is that account present in your Section Acces table? If not, add an ADMIN entry for the service account and reload before publishing this document.

Re: Section access QMC load issue

Remember, a service account is a Windows account. So it would need an NTNAME entry. Username and Password are for document security only, and have no relation to Windows accounts or Active Directory.

raju_salmon
Contributor

Re: Section access QMC load issue

Thanks Peter for the information. The server NTNAME i have added in section access table. My NTNAME is different than server NTNAME.

So you mean i need to load this qvw first in my local machine then i should move it to server?

Thanks,

Raju

raju_salmon
Contributor

Re: Section access QMC load issue

We have data restricted field called Store where i have added * in that entry for server NTNAME. Is it causing this issue? Other user have all values in multiple rows.

Highlighted
pradosh_thakur
Valued Contributor III

Re: Section access QMC load issue

hi

The SERVICE ACCOUNT is setup while installing the Qlikview server. It is responsible for all the reload and it should always have ADMIN access.

Your NTNAME will be domain name/username . if you want to use NTNAME security you have to add it , if not and you are using user name and password it shall work fine.

if this doesn't work share your section access script. I have ran into this kind of thing some days back hopefully will able to help you out.

Re: Section access QMC load issue

Whatever you put in the link field isn't that important, as long as you assign ACCESS=ADMIN to the service account. Even strict exclusion, won't have any effect on a reload.

To publish your document with Section Access, you can do one of two things:

  • Either place a QVW without loaded Section Access on your server, and let it be reloaded by the QDS to activate Section Access, or
  • Reload the document on your machine, so that Section Access becomes active immediately before publication but already includes the service account in the SA table.

Also check whether the NTNAME value for the service account includes the domain name (like domain\account) and is spelled correctly.

Best,

Peter

pradosh_thakur
Valued Contributor III

Re: Section access QMC load issue

hi

please add         star is *;    statement before section access.

try unchecking strict exclusion if doesn't reload

regards

Pradosh

raju_salmon
Contributor

Re: Section access QMC load issue

@Sure Peter, Thank you. Now receiving below error.

raju_salmon
Contributor

Re: Section access QMC load issue

Thanks Peter and Pradosh. It is working now.

Community Browser