Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Section access from CSV not working - user not found

Hello, the section access of Qlikview is driving me crazy.

I am loading data from a CSV file but when i try to enter the user it is not recognized.

Meaning I am prompted for a Username and when i enter admin, it asks me for a user name again.

Here the CSV LAYOUT I use

"ID","USERNAME"

"001","robert"

and here the Code i use in the script

AccessTable:

LOAD * INLINE [

ACCESS, USERID, PASSWORD

ADMIN, admin, admin

];

AccessTable_tmp:

LOAD [ID] as [USER_KEY]

,'ADMIN' as ACCESS

,[USERNAME] as [USERID]

,[USERNAME] as [PASSWORD]

FROM

"..\InputData\ref_ter_users-Copy.csv"

(txt, codepage is 1252, embedded labels, delimiter is ',', msq);

Concatenate(AccessTable)

load distinct ACCESS, USERID, PASSWORD resident AccessTable_tmp;

Section Access;

load ACCESS, USERID, PASSWORD resident AccessTable;

Section Application;

Anybody got a clue where my error is?

thanks

Robert

1 Solution

Accepted Solutions
Not applicable

Re: Section access from CSV not working - user not found

Try using uppercase for all field names and values on the Section Access, even for user names and IDs.

JG

2 Replies
Not applicable

Re: Section access from CSV not working - user not found

Try using uppercase for all field names and values on the Section Access, even for user names and IDs.

JG

Not applicable

Re: Section access from CSV not working - user not found

Thanks a lot for the fast reply. I almost thought that it was such a small thing.

Community Browser