Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Select Interface Language

Hi all,

Please can anyone let me know why my Qlikview is opening displaybox "Select Interface Language" everyweek.

Actually i'm running couple of QVW applications through "Task Scheduler" using batch files.

Now bcoz of displaying "Select Interface Language" my applications are not running completely in "Task Scheduler".

Greatly appreciated for your all ideas on this.

THanks in advance.

12 Replies
Not applicable

Re: Select Interface Language

Hi,

Please let me know if any one find same kind of issue and how can i handle this problem ?

Thanks in advance.

danielrozental
Honored Contributor II

Re: Select Interface Language

Make sure the user whose identity are the scheduled tasks running under has qlikview correctly configured and licensed assigned.

Employee
Employee

Re: Select Interface Language

The interface language is stored in the AppData folder (in Win7 C:\Users\<user>\AppData\Roaming\QlikTech\QlikView\Settings.ini).

If this file is missing or if the user does not have write permissions in this folder, you will get this problem.

HIC

Not applicable

Re: Select Interface Language

Thank You Henric.

Ok now i got some idea on this.

I had one doubt regarding this, if i didn't have License for Qlikview will it generate this issues "Select Interface Language" when i'm loading QVW file through batch file in Task Scheduler ?

Thanks in advance.

Employee
Employee

Re: Select Interface Language

QlikView can be run without a license. Then it will run as a Personal Edition. So, a lack of license should not be a problem.

But, under which account does this process run? And what happens if you log on to this account using a normal, manual logon? I suspect that you run it under an account that cannot create such a settings file. Or, you have some problem with a roaming profile that doesn't save the settings.ini.

HIC

Not applicable

Re: Select Interface Language

Hi Henric,

Thanks for reply.

But actually i'm able to view settings.ini file with my login authentications in

C:\ProgramData\QlikTech\QlikviewServer\

And i didn't got it fully the below point. Please can you explain  briefly.

Or, you have some problem with a roaming profile that doesn't save the settings.ini.

Thanks in advance.

Employee
Employee

Re: Select Interface Language

You said running "QVW applications through "Task Scheduler" using batch files." This means that you invoke QV.EXE from a batch file? Then the Settings.ini in the QlikViewServer folder is irrelevant.

The question is, can you access

C:\Users\<user>\AppData\Roaming\QlikTech\QlikView\Settings.ini).?

This is a roaming profile, i.e. if your computer is part of a domain, it is a profile that is handled by the domain controller.

HIC

Not applicable

Re: Select Interface Language

Hi Henric,

The question is, can you access

C:\Users\<user>\AppData\Roaming\QlikTech\QlikView\Settings.ini).?

Yes i can able access this with login authentication.

Thaks in advance.

Employee
Employee

Re: Select Interface Language

And if you add

InterfaceLanguage=English

right after the section header [Settings 7] ?

HIC


Community Browser