Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Services show as down in QMC once proxy server applied

Hi All,

We've recently migrated our QV environment to a new machine. All services are up and running, but once proxy server applied in IE settings (needed for google maps implementation) we get errors in the QMC that services are down. However, services show as running in the remote machine 'Services' portal. We know this has something to do with the proxy since once the settings are removed the QMC goes back to normal immediately.

services_down_3.png

Services_running_in_server.PNG

Any thoughts??

Thanks,

Taylor

6 Replies

Re: Services show as down in QMC once proxy server applied

Quite probably are now some important ports blocked, see: Qlikview Service- Listening Ports

- Marcus

Not applicable

Re: Services show as down in QMC once proxy server applied

Hi Marcus,

Thanks for your help. So just applying the proxy can block certain ports? How would I go about checking if a port is being blocked?

Thanks,

Taylor

Re: Services show as down in QMC once proxy server applied

You could try to check the ports with Ping (networking utility) - Wikipedia.

Beside them - what is the reason to transfer the qlikview server traffic over a proxy?

- Marcus

Not applicable

Re: Services show as down in QMC once proxy server applied

We are using a proxy server due to compliance restrictions. By using 'netstat' command it seems all QV-related ports are the same when the proxy is applied and when it's removed. Any other ideas?

Re: Services show as down in QMC once proxy server applied

The qlikview server services are quite sensitive and showing them as running within the task-manager doesn't meant that they are able to communicate correctly with eachother and are therefore working.

Maybe you could get more information or a hint by using the qlikview server super agent from the powertools. But I think you will need more efforts and using a network-sniffer to detect any delays within the communication (I think the timeout-span is quite small) and if some manipulation on the data happens (some years ago we had for testings also a proxy and in any way it changed the login-credentials and no authentication was possible).

Maybe pcammaert could give more hints what could be wrong.

- Marcus

Re: Services show as down in QMC once proxy server applied

Shouldn't you be excluding your intranet servers (like the one running QVS and assorted services) from the proxy server?

In most cases I am aware of (don't use proxy services myself), the entire intranet is excluded from the proxy cache.

Community Browser