Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

klaus_feldam
Contributor II

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

Background:

We have just installed QlikView 9 SR2 (9.0.7320.7 in 64-bit Windows environment). We are coming from a QlikView 8.20 Windows environment. We have 160+ QlikView files in approx. 50 different folders and have always been using NTFS to control access to individual users. Most users are local on the server and NOT domain users.

Our new server runs the QlikView Web Server as opposed to IIS (per recommendation from QlikTech). The server has 64GB and 8 processors.

---

Problem:

All users have severe performance issues on the initial startup page, AccessPoint (***Link Removed***), which takes 2-3 minutes to load. This happens consistently for all users in both IE7 and IE8.

Opening the same page in Mozilla Firefox or Google Chrome takes a couple of seconds.

We have ruled out any internal proxy settings as this is the same problem on/off network, on/off proxy, with domain users as well as local users, with company machines as well as private machines accessing over the internet.

The extreme load time of the QlikView Access Point also is an issue in IE on the server itself.

The top of the page opens quickly (seconds) and then 'hangs' - until the reports finally populate after 2-3 minutes.

error loading image

We have worked with QlikTech support who has been unable to help so far.

Below, are some of the test results:

Test 1 - IE:
> User: Internal domain user with access to 170 documents
> Open IE -> 9:46:00am

> Open Accesspoint (user credential typed in) -> 9:46:20am

> Access Point populated (authenticated and logged in) -> 9:48:25am (2min 5sec!)

> Open a QV document -> 9:49:00am

> Close the IE browser -> 9:49:10am

Test 2 - IE:
> User name: External user with access to 8 documents)
> Open IE -> 9:50:00am
> Open Accesspoint (user credential typed in) -> 9:50:35am
> Access Point populated (authenticated and logged in) -> 9:52:30am (1min 55sec!)
> Open a document -> 9:53:00am
> Close the IE browser -> 9:53:10am

Test 3 - Mozilla Firefox:
> User: Internal domain user with access to 170 documents
> Open Firefox -> 9:54:00am
> Open Accesspoint (user credential typed in) -> 9:54:05am
> Access Point populated (authenticated and logged in) -> 9:54:15am (10sec!)
> Open a QV document -> 9:54:25am
> Close the Firefox browser -> 9:54:30am

Test 4 - Mozilla Firefox:
> User name: External user with access to 8 documents)
> Open Firefox -> 9:56:00am
> Open Accesspoint (user credential typed in) -> 9:56:10am
> Access Point populated (authenticated and logged in) -> 9:56:15am (5sec!)
> Open a document -> 9:56:20am
> Close the fox browser -> 9:56:25am

Many thanks for any suggestions as this issue is bringing our implementation of QlikView 9 at risk.

1 Solution

Accepted Solutions
klaus_feldam
Contributor II

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

We have a solution to these extreme Internet Explorer issues.

I had to install QV9 SR6, which was released on Sept. 22, 2010. After installing the new release the AJAX client works equally fast in Internet Explorer and Mozilla Firefox.

The only drawback to this is that the old SR has to be un-installed first before you can install the new SR. A simple upgrade feature from QlikTech would have been desirable to avoid having to set-up and on configure important server configuration documents and settings all over again.

6 Replies

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

My first suggestion would be to upgrade to SR5. I encoutered several problems at the SR2 level.

If the IE user refreshes (F5) the AP page, does the refresh take as long as the initial load?

If you haven't already, you might try the Profiler built into IE8 to see where the time is going.
F12
Profiler
Start Profiling
Load the Page
Stop Proffling and review th results

-Rob

klaus_feldam
Contributor II

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

Rob,

Thanks for your reply. Below are the details of the Profiler results, which clearly shows the load issues being related to populating the page; 1) Paint_Thumbnails and UpdateClientsLinks on the Thumnail View and 2) Paint_Details and UpdateClientsLinks on the Details view.

Any comments on the below results would be greatly appreciated.

I will take a look at 9.00 SR5. Interesting that QlikTech support hasn't mentioned any of your suggested steps of addressing this very urgent issue.

Thanks for your assistance so far.

Klaus

klaus_feldam
Contributor II

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

QlikTech Support has recommended QlikView 9.00 SR6, which is due out on September 22, 2010.

I will give it a try and respond to this thread with my conclusion/findings.

Not applicable

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

Hi,

Did your issue got resolved by upgrading the s/w, i am also facing the same problem.

Regards,

Kingshuk

isaiah82
Contributor III

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

Hey Klaus > I believe I have run into this same problem before and was able to get around by moving the QVS server into the same subnet/VLAN as the local domain controller. I don't recall if I ever found the root cause but this had resolved the problem.

Hope this helps -Isaiah

klaus_feldam
Contributor II

Severe client performance issues loading QlikView Access Point in QlikView 9 SR2

We have a solution to these extreme Internet Explorer issues.

I had to install QV9 SR6, which was released on Sept. 22, 2010. After installing the new release the AJAX client works equally fast in Internet Explorer and Mozilla Firefox.

The only drawback to this is that the old SR has to be un-installed first before you can install the new SR. A simple upgrade feature from QlikTech would have been desirable to avoid having to set-up and on configure important server configuration documents and settings all over again.

Community Browser