Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Leverage your QlikView investment to modernize BI – see how! Join Group
Showing results for 
Search instead for 
Did you mean: 

Sharepoint Webparts not listing documents

Hi everyone,

I am currently trying to deploy QV WebParts on a test environment and I am facing some difficulties with the implementation.

My current scenario:

VMware virtual machine 1: QV Server 11.20 SR3 on Windows 7

VMware virtual machine 2: SharePoint Server 2010 and QV Webparts (for 11.20 SR3 build) on Windows Server 2008

I managed to install QV Webparts with a Proxy (because QV Server and Sharepoint are on different servers) on 2 and it's showing up as a Webpart in SharePoint, however NO documents are listed in the QlikView Object Selector:


The following settings are set/this is what I have tried:

- The QvAJAXZfc Path is correct and Proxy is set according to the installation manual and is listed on web.config.

- Authentication on QV server is set to Anonymous to avoid 'double hop' issues.

- FireWalls are turned OFF on both servers (for testing purposes).

- AccessPoint can be accessed by the machine 2 Webbrowser.

- Documents are viewable on Accesspoint for Anonymous and access is authorized for "All Users" on QMC

- I can even implement AccessPoint within a Page Viewer Webpart in SharePoint.

- Security settings, blocked file endings etc. are all set to OFF on SharePoint

- There are enough CAL sessions available.

- WebParts;YES is listed in the LEF.txt so the license for WebParts is available.

- There are no entries made in the Events or Sessions logs of QV the server while trying to add the Webparts object.

- I have NOT tried using a Kerberos authentication, because in my view at this point it's not necessary when I don't need an authentication on the QlikView server (set to anonymous).

As you can see, I am a little bit stuck and I would appreciate help or ideas from anyone who has experience with this subject.

Thanks a lot,


3 Replies

Re: Sharepoint Webparts not listing documents

I made a little progress and tried many things to solve this issue. It comes down to the problem, that each time I add an QlikView Webpart into SharePoint, I get an error in Internet Explorer 8.0, that 'Qva is undefined' when initializing the page. So obviously the Webpart is not working correctly which is why I am having connection issues. Any ideas what the reason might be for this?

Contributor II
Contributor II

Re: Sharepoint Webparts not listing documents

Hi Martin,

I know this is a very old thread but I am wondering if you found a solution to this issue as I am having the same exact problem.




Re: Sharepoint Webparts not listing documents

I ended up installing a different version of SharePoint