Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Strange problem in data load

Hi,

I have one document that it works from 1 years without problems.

Now the load for one table doesn't run.

If I copy the qvw and paste it in another folder it runs correctly.

It's don't give me one error message, but only "Load Completed"

What is this?

10 Replies
dmohanty
Valued Contributor

Re: Strange problem in data load

Can you please throw more light one this?

If your table is failing to Load, can you post the script of the table and the Error Message you are getting? Better check the Logs of the QVW.

Not applicable

Re: Strange problem in data load

My script is it. I haven't details in the log only this. If i move this qvw into another directory it's run perfectly!

04/10/2013 10:10:56: 0128Store Vendor into qvd\Vendor.qvd(qvd)
04/10/2013 10:10:56:     General Script Error

Vendor:

SQL

SELECT    

        [Vendor No_],

        [Language Code]   

FROM         dbo.[local$vendor]

WHERE     ([Language Code] = 'E');

Store [Vendor] into qvd\Vendor.qvd (qvd);

Customer:

SQL

SELECT    

        [Vendor No_],

        [Customer No_],

        [Customer Desc]

FROM         dbo.[local$Customer];

Store [Customer] into qvd\Customer.qvd (qvd);

Not applicable

Re: Strange problem in data load

Did you try to reduce data (remove all data and keep all object) and then reload?

Did you get the same error?

Regards

Corrado.

Employee
Employee

Re: Strange problem in data load

Check the path, this error is "common" when QlikView can´t write a file.

I would check

1) Folder permissions

2) Folder Exists?

3) Customer.qvd permissions

Not applicable

Re: Strange problem in data load

Yes... the same error.

The absurd is that if copy the directory and I paste all files into another it runs perfectly or If i change the name from Vendor in VendorX in the same directory it runs.

dmohanty
Valued Contributor

Re: Strange problem in data load

The problem clearly is that somehow the particular QVD lost the write access. If somehow the QVD is being opened by some other app or someone else is trying to acces that QVD, script wont be able to overwrite the QVD.

No need to move the QVW anywhere else, just move all the QVDs in a BackUp folder and let the QVW generate fresh QVDs.
No change required in scripting part!!!

Not applicable

Re: Strange problem in data load

I thinked it previously

I deleted all qvd and the subfolder qvd but I don't resolve the problem.

The qvw make the vendor and customer qvd file but it doesn't go to the next instruction.

Until yesterday the qvw as worked for 1 years without problems.

Not applicable

Re: Strange problem in data load

now i see that everytime that i make a reload the vendors.qvd lost the write permission.

But only this qvw use this qvd!

dmohanty
Valued Contributor

Re: Strange problem in data load

Somehow, the QVD is open or something like that. We have faced problems like this which are unknown.

Do one thing: Remove/Delete that QVD and let the QVW generate it fresh. You wont face problems again!!!