Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Unable to start a DCOM Server: ... The error: "299" - qvb.exe

Hello,

since 3 weeks we have got following error in the Windows Events:

Event 100, DistributedCOM

Unable to start a DCOM Server: {BE1F19B5-415E-11D1-934D-0040333C91CC}. The error: "299"

Happened while starting this command:

"C:\Program Files\QlikView\Distribution Service\qvb.exe"-Embedding

pwagner_0-1599568514827.png

 

Unfortunately I cannot find a suitable advice how to solve this issue.

Has anybody an idea for this topic?

 

Thank you.

Best regards,

Patrick

 

1 Solution

Accepted Solutions
Highlighted
Digital Support
Digital Support

Hello @pwagner 

Not certain based on this alone. But 299 according to some research seems to indicate a resource issue (based on results for this error code from Windows).

What other symptoms are you seeing? Are tasks not loading? Is this constantly being logged? What happens after a server restart? 

Do our logs show anything?

For DCOM errors when registering the QVB in general, I would recommend those two steps:

Make sure the QVB is correctly registered: 

  1. Open windows file explorer
  2. Locate qvb.exe, default location C:\Program Files\QlikView\Distribution Service\
  3. Double click on qvb.exe to create the necessary Windows registry keys and GUID.
  4. Restart machine to make sure registry changes are properly applied


Make sure the permissions are correct

  1. Run "DCOMCNFG.EXE"
  2. Expand the Console Root  => Component Services => Computers => My Computer => DCOM Config
  3. Locate "QlikViewBatch 7.0 Application", right click and choose properties
  4. Select the "Security" tab, then "Customize" on the "Launch and Activation Permissions", and then press "Edit"
  5. Add the account that needs launch permissions (the service account running the QlikView Distribution Service)
  6. Check the options "Local Launch", "Remote Launch", "Local Activation", and "Remote Activation"
  7. Save and try starting the QlikView Distribution Service
  8. If it still fails, repeat steps 4-7 for the "Access Permissions" and "Configuration Permissions" sections on the "Security" tab

Hope some of this helps you get this resolved.

/Sonja

Don't forget to Like posts and use the "Accept as Solution" button on content that answered your question! Thanks 🙂

View solution in original post

1 Reply
Highlighted
Digital Support
Digital Support

Hello @pwagner 

Not certain based on this alone. But 299 according to some research seems to indicate a resource issue (based on results for this error code from Windows).

What other symptoms are you seeing? Are tasks not loading? Is this constantly being logged? What happens after a server restart? 

Do our logs show anything?

For DCOM errors when registering the QVB in general, I would recommend those two steps:

Make sure the QVB is correctly registered: 

  1. Open windows file explorer
  2. Locate qvb.exe, default location C:\Program Files\QlikView\Distribution Service\
  3. Double click on qvb.exe to create the necessary Windows registry keys and GUID.
  4. Restart machine to make sure registry changes are properly applied


Make sure the permissions are correct

  1. Run "DCOMCNFG.EXE"
  2. Expand the Console Root  => Component Services => Computers => My Computer => DCOM Config
  3. Locate "QlikViewBatch 7.0 Application", right click and choose properties
  4. Select the "Security" tab, then "Customize" on the "Launch and Activation Permissions", and then press "Edit"
  5. Add the account that needs launch permissions (the service account running the QlikView Distribution Service)
  6. Check the options "Local Launch", "Remote Launch", "Local Activation", and "Remote Activation"
  7. Save and try starting the QlikView Distribution Service
  8. If it still fails, repeat steps 4-7 for the "Access Permissions" and "Configuration Permissions" sections on the "Security" tab

Hope some of this helps you get this resolved.

/Sonja

Don't forget to Like posts and use the "Accept as Solution" button on content that answered your question! Thanks 🙂

View solution in original post