Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Variable behaves differently on Server

Hi.

I am baffled. I've got a variable that works fine on my desktop and on a staging server, but once on the production access point, the variable comes up null (using the same data and filters.

The variable's name is vQBRFYstartMonthDate, as is defined as:

=Addmonths(IF($(vQBRFYstartMonth)=1,

NUM(makedate($(vQBRDYselectedYear),$(vQBRFYstartMonth)+11)),

NUM(makedate($(vQBRDYselectedYear),$(vQBRFYstartMonth)-1))),-11)

This returns a date.


On the server, the variable fails, but the funtion works find. Yet on my local file and on a staging server, the variable works fine.

What give? I hope I am not overloking something silly...

24 Replies
Employee
Employee

Re: Variable behaves differently on Server

Let me ask a silly question

All others variables are set?

vQBRFYstartMonth

vQBRDYselectedYear

vQBRFYstartMonth

Not applicable

Re: Variable behaves differently on Server

Yes (One can never be too silly)

I have tested all three separately and they work fine, but anyways, the entire line works fine when called dirrectly, It's the variable that is failing (but only on the server). I have also tried to call the variable three different ways:

=vQBRFYstartMonthDate

=$(vQBRFYstartMonthDate)

='$(vQBRFYstartMonthDate)'

Employee
Employee

Re: Variable behaves differently on Server

Where are using this variable? Try to put

=vQBRFYstartMonthDate into a textbox and check what it returns

Not applicable

Re: Variable behaves differently on Server

Thanks how I am testing them. i.e by putting them in a text box.

Employee
Employee

Re: Variable behaves differently on Server

Did you try both plugin and ajax?

Not applicable

Re: Variable behaves differently on Server

Hadn’t tried Ajax. But I just did and it is the same problem.

Employee
Employee

Re: Variable behaves differently on Server

I can´t see a reason.

The app is exactly the same? Or into your prod server you´ve reloaded the app?

Not applicable

Re: Variable behaves differently on Server

I am not sure I understand but I think the app is reloaded, since I am pushing a full qvw file to the server.

Employee
Employee

Re: Variable behaves differently on Server

If you copy your production qvw and open it using your desktop, the issue persists?

Community Browser