Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Warning: Failed to Read in server log

I have been looking at the server logs on our server and I have a number of rows with, warning: Failed to read from C:\Databases\QvDocuments: Access Denied. User=username, ImpLev=1. All these users are able to access the document successfully, but I am trying to understand why i have this warning in my logs.

All users are a part of a Group that has Read access to the Documents folder.

Does anyone else have this issue?

1 Solution

Accepted Solutions
Employee
Employee

SV:Re: SV:Re: SV:Warning: Failed to Read in server log

If I recall correctly, in 8.5 (guess that's the version you're running) there's no way to hide files by setting permissions on the actual file. It must be set on the folder for the folder to be "hidden". You will still be able to see the files, but not access them (unless NTFS-permissions allow it of course).

You could of course mount the folder and make sure "Browsable" is unchecked, but then it won't show up for Admins either. You need to know the exact path and file-name to be able to open the document (like qvp://server/admins/somefile.qvw)

6 Replies
Employee
Employee

SV:Warning: Failed to Read in server log

The only thing I can think of on the top of my head is that you have Allow Anonymous Access enabled in QVS Management. It could be that when accessing the file the first time, QVS will try doing this using the anonymous account (IQVS_<computer>). It will fail, as this account does not have access to the file according to NTFS. Next, it will try opening the file as an authenticated user, and the user will get access (if NTFS-permissions are correct).

Web server works in a similar way, where you will get a 401 reply when trying to access a secured page. Then client-server will negotiate on which protocol to be used for authentication and you will be able to access the page (if you're authorized to do so).

If setting the server to Prohibit Anonymous does not take care of the warnings, I will see if I can look into exactly when and why this is happening.

Not applicable

SV:Warning: Failed to Read in server log

Under the Security tab in QVS Management, I have "Prohibit Anonymous" selected under "Windows Client"; Anonymous Account section has "On Local Computer" selected, and; Separate Java Settings is checked with "Allow Anonymous" selected.

ALL users of the QVS are using IE plug-in and are on the local network.

Any suggestions on next step?

Employee
Employee

SV:Re: SV:Warning: Failed to Read in server log

Could it be that you're having other folders in the C:\Databases\Qvdocuments and set the C:\Databases as the root folder?

This warning simply indicates that when QVS is trying to traverse all files and folders in the path for a given user, some files (or folders) can't be accessed. It will for example occur if you do the following:

Create a folder C:\QvDocs

Creates sub-folders, like C:\QvDocs\Admins and C:\QvDocs\Users

Add C:\QvDocs as the root-folder in QVS.

Gives different permissions for users/admins on the sub-folders.
Not applicable

SV:Re: SV:Warning: Failed to Read in server log

You hit it spot on.

We have two sub folders that that are only given access to admin users whereas the root folder provides the general QVW files. If I give users access to the sub folders, then the QVD files, etc. that we store in the subfolders show up on the list of documents which we do not want the users to see. Before I make any changes to the NTFS permissions on the sub folder, can you tell me if there is any way to restrict the QVW documents that the users see on the list of documents that they are allowed access to from their browser?

Employee
Employee

SV:Re: SV:Re: SV:Warning: Failed to Read in server log

If I recall correctly, in 8.5 (guess that's the version you're running) there's no way to hide files by setting permissions on the actual file. It must be set on the folder for the folder to be "hidden". You will still be able to see the files, but not access them (unless NTFS-permissions allow it of course).

You could of course mount the folder and make sure "Browsable" is unchecked, but then it won't show up for Admins either. You need to know the exact path and file-name to be able to open the document (like qvp://server/admins/somefile.qvw)

Not applicable

SV:Re: SV:Re: SV:Warning: Failed to Read in server log

Thank Bjorn. That definitely helps. We will go for the second option with Browsable unchecked and create shortcuts with hyperlinks on the site to allow users to open the QVW files that the need to.

Thank you.