Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Web Parts Installation

Hey Guys,

I'm trying to install QV Web Parts for Sharepoint but I'm coming across this error. I have completed part 1 through 5 from

http://community.qlik.com/wikis/qvwebparts9/default.aspx

Restarted IIS and the server and still got the error. When I convert back to the old web.config file sharepoint works again.

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web> <customErrors mode="Off"/> </system.web></configuration>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web></configuration>


Server Error in '/' Application.


Server Error in '/' Application.

Runtime Error

1 Solution

Accepted Solutions
Not applicable

Web Parts Installation

Hey Guys,

If you come across this error first you must find out what the true error is. Open the web.config file and change On to Off like below. Don't foreget to change back when your done!

<code xml><customErrors mode="On" /></code>

And changing it to:

<code xml><customErrors mode="Off" /></code>

This should result in more useful information in diagnosing the problem.

6 Replies
Not applicable

Web Parts Installation

Hi Kristen,

Did you manage to find a solution to this problem?

Only I am also attempting to install the "QV Web Parts for Sharepoint" and have come across the same (or similar) problem.

Have followed the "installation guide", but am receiving the following error:

Server Error in '/' Application.


Server Error in '/' Application.

Security Exception

Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'Microsoft.SharePoint.Security.SharePointPermission, Microsoft.SharePoint.Security, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' failed.

Stack Trace:

[SecurityException: Request for the permission of type 'Microsoft.SharePoint.Security.SharePointPermission, Microsoft.SharePoint.Security, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' failed.] Microsoft.SharePoint.WebControls.TemplateBasedControl.get_Controls() +39 QT.QWW.Support.QvDataSourceFinder.findDataSourceByID(String qvDataSourceId, Control control) +606 QT.QWW.Support.QvDataSourceFinder.findDataSourceByID(String qvDataSourceId, Control control) +680 QT.QWW.Support.QvDataSourceFinder.findDataSourceByID(String qvDataSourceId, Control control) +680 QT.QWW.Support.QvDataSourceFinder.findDataSourceByID(String qvDataSourceId, Control control) +680 QT.QWW.Support.QvDataSourceFinder.findDataSourceByID(String qvDataSourceId, Control control) +680 QT.QWW.Support.QvDataSourceFinder.findDataSourceByID(String qvDataSourceId, Control control) +680 QT.QWW.Support.QvDataSourceFinder.FindDataSourceByID(Control controlStart, String id) +457 QT.QWW.WebControls.QvObjectBase.discoverDataSource() +78 QT.QWW.WebControls.QvObjectBase.RegisterStyleSheetInInHeader() +29 QT.QWW.WebControls.QvObjectBase.OnPreRender(EventArgs e) +24 System.Web.UI.Control.PreRenderRecursiveInternal() +108 System.Web.UI.Control.PreRenderRecursiveInternal() +224 System.Web.UI.Control.PreRenderRecursiveInternal() +224 System.Web.UI.Control.PreRenderRecursiveInternal() +224 System.Web.UI.Control.PreRenderRecursiveInternal() +224 System.Web.UI.Control.PreRenderRecursiveInternal() +224 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11035559 System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +11035098 System.Web.UI.Page.ProcessRequest() +91 System.Web.UI.Page.ProcessRequest(HttpContext context) +240 ASP.WELCOMELINKS_ASPX__1240452380.ProcessRequest(HttpContext context) +9 Microsoft.SharePoint.Publishing.TemplateRedirectionPage.ProcessRequest(HttpContext context) +283 System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +599 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +171

The problem appears to be related to the "SharePoint trust/security policy settings" detailed in step 4)

Changing the "Trust level" to "Full" (<trust level="Full" originUrl="" />) does prevent the error, but obviously leaving the config in "Full Trust Mode" isn't really an option for a production environment.

Regards

AObi

Not applicable

Web Parts Installation

Hey AObi,

I haven't been able to fix mine yet.

I did notice on the trust setting to make sure the PublicKeyBlob runs on one line with no new lines (no enters).

Not applicable

Web Parts Installation

Thanks for the suggestion Kristen,

But unfortunately that's not the problem (already made sure PublicKeyBlob is on one line).

The problem appears to be due the CAS (Code Access Security) Security Policy is not getting referenced / picked up correctly.

Not applicable

Web Parts Installation

Hey Guys,

If you come across this error first you must find out what the true error is. Open the web.config file and change On to Off like below. Don't foreget to change back when your done!

<code xml><customErrors mode="On" /></code>

And changing it to:

<code xml><customErrors mode="Off" /></code>

This should result in more useful information in diagnosing the problem.

Support
Support

Web Parts Installation

Your error is most likely due to wrong settings in the policy file. I guess everything works fine if you set the trust to Full? If yes, focus on the policy file created. Please find attached an example policy file for reference.

Not applicable

Web Parts Installation

Thanks Bjorn,

Think I have also identified the cause of the problem...

The CodeGroup detailed in the installation documentation (http://community.qlik.com/wikis/qvwebparts9/part-4-sharepoint-trust-settings.aspx) is different / incorrect....

<CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="QlikViewWebParts"> <IMembershipCondition version="1" class="StrongNameMembershipCondition" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100a53dfbeabd38a568ece7bf2dbac63ea
213ea4944ad4aa432a72a0723ac9d80ebd7a52fbe49632dc824df7e858361043e69436f277362c8eb0147572891f2ba131966203dca15a
c49dd4363344aaeb9e386a24cd144bab2062f01a6c1e1cbd4b68e319d9f9b7ee82826d354753a08547ea0b19728bc6c1a681d419cd3619
27dbc" Name="QlikWebWorkBench"></IMembershipCondition>

</CodeGroup>

Where as yours is...

<CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="QlikViewWebParts">
<IMembershipCondition version="1" class="StrongNameMembershipCondition" PublicKeyBlob="0x0024000004800000940000000602000000240000525341310004000001000
10093D8EABE32C8748C0E248C26A1A0CDD168EAF26399AAC805874666B9F4BFCE1E682E2B42574F8F64DEF4315477
D07BDCD78C0FCF7012ED3E6A7680C7F245C029D72EF951A5CA200C898168C4309F1A3967
8EAF558754ED1AB52948A789AA65BCCACB3575C344752EC9F66A559A82C992C06BE77D97
BAF14388CCD3185C9714C1"/>
</CodeGroup>