Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Web version loses the browser connection every now and then when changing through report tabs

This is the problem, our web version of the reports loses the browser connection quite often when selecting a new tab (first qlikview alert says that "Server connection lost - reconnecting.." and in a moment the browser informs that "no connection") . We have around 30 tabs in total which have conditional visibilities.

I haven't been able to figure out a pattern which causes these connection losses, and I'm not sure if the conditional visibility is even relevant. I've been trying to find if there is a specific tab that causes this but none of them seem to affect it. It can crash at any tab, after any tab. Sometimes I'm able to change tabs inside one set infinitely when no visibility changes happen and then when I open a new set it quickly loses the connection (after 1-5 tab changes). But the problem is that it is not limited to this. Sometimes, but rarely, it will crash even though only one set has been opened and then browsed through without any tabs becoming hidden again.

I'm completely clueless where the problem might be since I haven't been able to find any pattern in it at all. Any leads where to look?

7 Replies
MVP
MVP

Web version loses the browser connection every now and then when changing through report tabs

Hello Henry,

First of all take a look at the document and session timeouts in both the document and the server.

In the document, go to the Settings menu, Document Properties, Server tab and set both Maximum Inactive and Maximum Total Session timeouts.

In the server go to the QEMC, System, Setup, QlikView Servers, expand and click on yours, go to the right side to the tabs Documents and Performance where you will see different timeout values there.

Play with them with a few minutes (say 10) so you can control that a document keeps open for those 10 minutes.

Hope that helps.

Not applicable

Web version loses the browser connection every now and then when changing through report tabs

This doesn't seem to be an session timeout issue since the crashing doesn't correlate with the time used. I did some testing and found out that the conditional visibility seems to be the cause of the crashes. We have sets of sheets which are opened by clicking the set master sheet. This causes the variable ShowSet to change value to A, B, C and so on and the sheets have a visibility conditions like ShowSet='A'.

MVP
MVP

Web version loses the browser connection every now and then when changing through report tabs

Hello Henry,

Is there any section access related to that visibility? Or is the user who selects at the opening of the document? Does that happen with all clients (Desktop, Plugin, AJAX)?

Regards.

Not applicable

Web version loses the browser connection every now and then when changing through report tabs

Not sure what is meant by section access, so probably no. At the start only the master sheets are visible and user selects one of them, which makes the whole set visible. Selecting another master sheet will cause the another set to become visible and hides the previous one. The user makes all the selections and changing variable value and conditional visibilities keep hiding and showing appropriate sheets.

This only happens when used through the website. The same file on desktop works fine.

We were thinking of trying to create this navigation logic through macros hoping it would work better but I haven't been able to find out how to hide & show sheets with macros. I guess that's another question anyway.

MVP
MVP

Web version loses the browser connection every now and then when changing through report tabs

Section access means you are setting additional security in your script, a piece of code that always start with "Section Access;"

Is that a field, in a logic island (a table that is not related to the rest of the data model) or is a variable that stores "A", "B", "C"...

You can set the visibility of any object by macro, but if possible I always try to avoid them, since they are not fully supported in clients (specially AJAX), and they may cause unexpected behavior. That doesn't mean that they are not going to work, they do, actually. But it might be another source of issues.

If the client is Plugin, is this the same version than the server? Have you tried assigning numeric values instead of literals (FIeld = 1 instead of Field = 'A').

Hoep that helps.

Not applicable

Web version loses the browser connection every now and then when changing through report tabs

Okay, I've finally found the pattern which causes the crashes and also the main suspect. The crashes happen if the user opens a sheet that has been hidden and that has a container within, and then opens another set and opens another sheet with a container. Somehow this causes the crash. These containers are also linked to listboxes where you can select the dimensions for the graphs. Opening sheets without containers does not affect anything and it will never crash if only these are selected.

This pattern was pretty hard to find, and I suspected the conditional visibility to be the problem because this does not happen if the sheets with containers are always visible. I'm thinking should I start a new post with this more clearly defined issue? I will do some more tests anyway to fully confirm that it is the container that is causing the problems.

MVP
MVP

Web version loses the browser connection every now and then when changing through report tabs

Hi Henry,

Glad to hear that at least you have identified the issue. I think it's worth sending an email to the support team so they can confirm whether this is a bug. They will ask you for all the tests you have already done and under what circumstances do you see that happening. The more information you send them the easier for them will be to check them.

Make sure you are running the last stable version of client, plugin and server (Version 10 SR1 build 8815.6) and if not check for the relase notes to see if there is any reported bug about it.

Regards.

Community Browser