Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Webpageviewer extension in QV10 SR1

It appears that the webpageviewer qar found in the examples folder in QV10 SR1 does not work. I had to revert back to the qar file in QV 10 IR to get web pages to display correctly within the application. Please note that if you already installed the IR extension, the SR1 upgrade does not impede or stop the webpageviewer functionality. It's only if you try installing the SR1 qar without having first installed the IR qar.

If anyone (or Qliktech) has any news to the contrary, please let me know. Thanks!

8 Replies
jtg
Valued Contributor

Webpageviewer extension in QV10 SR1

It appears that the creation of the QAR file for the webpageviewer is indeed corrupt with the SR1 package. Attached is a version that you or anyone else looking for this extension should be able to access and use. (You'll need to rename it from a TXT file to a QAR file before double clicking to install).

Regards

John Trigg

Edited - removed TXT file as led to corrupt file on download. Please see post below (ZIP file attachment) for what should be the correct version

Not applicable

Webpageviewer extension in QV10 SR1

Thanks John, appreciate the quick response. When I tried to install the new extension, I get an invalid archive, 0 files in 0 directories response. I'm guessing this is not expected behavior?

jtg
Valued Contributor

Webpageviewer extension in QV10 SR1

OK having trouble attaching as the pure QAR file. So here it is in ZIP form. Let me know success or fail

marcel_olmo
Contributor III

Webpageviewer extension in QV10 SR1

Hey John, thanks for fixing this.

I've noticed that WebPageViewer.qar fails on QV10 SR1, but it worked fine on the QV 10 IR (I know that because a colleague has that installation). So I've fixed that copying the qar file from the IR to my SR1.

When are you planning to fix this little bug in put it into the QV10 SR1 installer?

Many thanks in advance!!!

jtg
Valued Contributor

Webpageviewer extension in QV10 SR1

Probably SR2 at this time

Not applicable

Webpageviewer extension in QV10 SR1

John,

Maybe you can shed some light on some things. I am in a 2 server environment with a front facing IIS Server and then QVS on another server. I am using the WebPageViewer Extension. It does not seem to work in this config. I have dropped the Extension in the programdata/qliktech/qlikviewserver/extensions/objects/webpageviewer. I modified the .js file to reference the directories below extensions but it still is not working. I can see the control and can add it to my qvw but it just won't show up through the ajax interface.

jtg
Valued Contributor

Webpageviewer extension in QV10 SR1

Am doing some digging around to see what I can find out. Will report back when I have something to report

idaphne00
New Contributor

Re: Webpageviewer extension in QV10 SR1

tenia el mismo problema, pero la version no es el inconveniente. yo tengo la 10 SR1 y la instalacion del qar funciono con el zip que publicaste. gracias!

Community Browser