Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Webparts for Sharepoint DataSource Error

Hey Guys,

I'm getting this message when I try to add the datasource web part in sharepoint. Has anyone seen this before or might know what I might get it? The QV server is on a different server than the Sharepoint. Port 4747 is open. I have changed the localhost to the qv ip address for the rows below

<add key="QvsHost" value="localhost" />

Error: Error System.ApplicationException: Failed to create new QvClient, first attemptSmiley Frustratedystem.Net.Sockets.SocketException: A blocking operation was interrupted by a call to WSACancelBlockingCall at QlikTech.NetClient.QVClient.GetMessageDataFromSocket

error loading image

16 Replies
Employee
Employee

Webparts for Sharepoint DataSource Error

Hi Kristen,
Is this with or without Full trust? First try and set the trust="Full" (i.e. no policies) in web.config. Try to get this to work before digging into the policy/trust file. Attached is a document (draft) and example web.config / minimal.config to be used as a reference (do not replace your existing config files with the attached ones as this might break other settings in your MOSS installation.

Regards,
Bjorn

Employee
Employee

Webparts for Sharepoint DataSource Error

minimal trust

Employee
Employee

Webparts for Sharepoint DataSource Error

draft documentation

Not applicable

Webparts for Sharepoint DataSource Error

Hey Bjorn,

Thanks for replying.

I first tried to get the web parts working with the specific trust level from the wiki documentation online http://community.qlik.com/wikis/qvwebparts9/default.aspx

But that didn't work.

Then I found the same document you sent in another discussion and followed each step. I'm stuck on page 5 where you add the datasource with full trust. I tried restarting both servers.

I noticed a few places in your config file where the additions were added before previous code. So, I changed mine to reflect that. For example, yours was this:

<httpHandlers>
<!-- ADDED -->
<add verb="*" path="QvsViewClientEx.ashx" validate="false" type="QT.QWW.Framework.QvsViewClientEx, QlikViewWebParts" />
<add verb="*" path="QWWService.ashx" validate="false" type="QT.QWW.Framework.QWWService, QlikViewWebParts" />
<remove verb="GET,HEAD,POST" path="*" />
<add verb="GET,HEAD,POST" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
<add verb="OPTIONS,PROPFIND,PUT,LOCK,UNLOCK,MOVE,COPY,GETLIB,PROPPATCH,MKCOL,DELETE,(GETSOURCE),(HEADSOURCE),(POSTSOURCE)" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
<add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
</httpHandlers>

And Mine was:

<httpHandlers>
<remove verb="GET,HEAD,POST" path="*" />
<add verb="GET,HEAD,POST" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
<add verb="OPTIONS,PROPFIND,PUT,LOCK,UNLOCK,MOVE,COPY,GETLIB,PROPPATCH,MKCOL,DELETE,(GETSOURCE),(HEADSOURCE),(POSTSOURCE)" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
<add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
<add verb="*" path="QvsViewClientEx.ashx" validate="false" type="QT.QWW.Framework.QvsViewClientEx, QlikViewWebParts" />
<add verb="*" path="QWWService.ashx" validate="false" type="QT.QWW.Framework.QWWService, QlikViewWebParts" />
</httpHandlers>

Then I restarted IIS, deleted the webpart and added a new one and still get the error.

Update: I decided to delete the old files I worked on and uninstall QV webparts from the SP server. Then I followed each step of the document and used your config file as a guide when editing that. Well, I still got the error. My IT guys tell me port 4747 is open. So, I'm really stuck.

Employee
Employee

Webparts for Sharepoint DataSource Error

Hmm...sounds pretty strange. The order for the http handlers doesn't matter, so no problem adding them first or at the bottom of the <httpHandlers> section in web.config

I wonder if you got the correct web parts? Do you have two dll:s in the bin-folder named:
- QlikViewWebParts.dll
- QvsnetRemoteWB.dll

Also did you use the default settings for the DataSource, i.e. you didn't alter any of the settings (for example trying QlikX client instead of ZFC client)?

Not applicable

Webparts for Sharepoint DataSource Error

That is strange my files are named a little different

QlikViewWebParts.dll (same)

QvsNetRemote.dll (the Net is cap..does that matter?..should I change it to what you have?)

I left the settings for the DataSource as default.

I'm on version 9.0.7320.7 for Server and webparts.

Employee
Employee

Webparts for Sharepoint DataSource Error

Ah, that explains it. The DLL:s has been changed and the instructions given are for 7440 or later. I suggest you download the webparts for 7440 or later and try those DLL:s instead (just copy them into the /bin folder).

You shouldn't have to upgrade the QVS afak.

Not applicable

Webparts for Sharepoint DataSource Error

I have uninstalled and reinstalled with 7440. Then I deleted the old dll files and copy/paste the new ones. And... Hurray that error is gone, but a new one showed up in it's place. I have tried both the IP address and the servername. I have restarted IIS as well. I have put Films.qvw in as the QlikViewDocument in the DataSource Web Part. (Which is in our QV document folder..Not on the c drive but it does show up in our accesspoint)

It says Could not connect to usvqv1.

Does that mean I need to upgrade my server to the same build or could it be something else?

Not applicable

Webparts for Sharepoint DataSource Error

I found this in the event log

2010-09-22 11:57:46 2010-09-24 10:36:30 4 504 Information Session stop reason: can't authenticate

2010-09-22 11:57:46 2010-09-24 10:36:40 4 504 Information Session stop reason: can't authenticate

2010-09-22 11:57:46 2010-09-24 10:37:00 4 504 Information Session stop reason: can't authenticate