Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Why do I see my mounted folders twice in the User Documents tab in QEMC?

Hi,

I have mounted three folders under my root folder on QVS called DEV, TEST and PROD and have provided them names Development, Test and Production respectively. When I go to the user documents tab on QEMC, I see the actual folders listed and also the aliases listed separately. Thus I see, DEV,TEST, PROD and Development,Test and Production listed thus giving the impression that I have six user document folders.

However when I want to redistribute any qvw, I only see names of the mounted folders (Development, Test, Production) while defining the task. But when I open up Accesspoint, it shows the thumbnail of the document twice which is quite confusing.

I am using QVS 9 SR5.

Can someone let me know what I am missing here?

Thanks,

Tags (2)
1 Solution

Accepted Solutions
vgutkovsky
Honored Contributor II

Why do I see my mounted folders twice in the User Documents tab in QEMC?

I'm guessing the folders are not at the lowest level. All mounts need to be at the lowest folder level to avoid this type of behavior. So your User Documents structure could look like this:

  1. C:\
    1. Documents
      1. (empty)
      2. DEV
      3. TEST
      4. PROD


In this scenario, you would want to avoid setting the root User Documents folder to "Documents." Rather, make the root the "(empty)" folder and DEV, TEST, and PROD should be mounts. That should fix the duplication.

Regards,

3 Replies
vgutkovsky
Honored Contributor II

Why do I see my mounted folders twice in the User Documents tab in QEMC?

I'm guessing the folders are not at the lowest level. All mounts need to be at the lowest folder level to avoid this type of behavior. So your User Documents structure could look like this:

  1. C:\
    1. Documents
      1. (empty)
      2. DEV
      3. TEST
      4. PROD


In this scenario, you would want to avoid setting the root User Documents folder to "Documents." Rather, make the root the "(empty)" folder and DEV, TEST, and PROD should be mounts. That should fix the duplication.

Regards,

Not applicable

Why do I see my mounted folders twice in the User Documents tab in QEMC?

Thanks Vlad.

That worked like a charm. But I still believe it s a little cumbersome having to set up the user documents this way. I had thought (wrongly, as it turns out) that the root folder meant the root folder of my user documents. However, it looks like the mounted folders and the root folder need not have any relationship at all.

Thanks,

vgutkovsky
Honored Contributor II

Why do I see my mounted folders twice in the User Documents tab in QEMC?

You're right, it's only a logical relationship and no physical relationship is needed at all.

Regards,

Community Browser