Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

dmz server configure

Hi Guys,

I would like to give users external access withouth VPN.

I can connect from server A(internal QV server) to dmz server > i added the dmz server in QMC and there is no error there.

But when i open the accesspoint in the dmz server i get an error message: no server.

- I've temporarly opened all ports between server A and the dmz server

- selected in QMC the correct server to connect: QVS@serverA (accespoint>serverconnection>name)

- i've installed on the dmz only the webserver (no iis)

I did not configure any authorization allthough i would like to use Active directory also in DMZ, but this will propably not work. My other option is local users on dmz (or DMS settings if its only possible to only configure for the DMZ server, and still use AD internaly)

But i for some reason i cannot connect to server A.

Am i missing something? (could it be the login credentials in the services qlikview webservice or the login in the QMC?)

Labels (1)
1 Solution

Accepted Solutions
Employee
Employee

Re: dmz server configure

Hi,

OK, then lets try this. On the Machine that is running QVS, try to create a local User that is the same as the user in the DMZ and use the same password. Make this user a member of the QlikView Administrator group.

Let me know what happens.

Bill

18 Replies
Employee
Employee

Re: dmz server configure

Hi,

Did you edit the Webserver config.xlm file to point to the QlikView Server? It is located at C:\ProgramData\QlikTech\WebServer

Bill

Not applicable

Re: dmz server configure

Hi Bill,

Thanks for your reply.

I've looked into that config file. It also seems to point to the qlikview server. In the log files it tries to connect to server A but it fails.

I did not edit the config file.What should i edit?

Employee
Employee

Re: Re: dmz server configure

HI,

You will need to change

<AddCluster>

    <Name>QVS@qvlab</Name>

    <LoadBalancing>CpuUsage</LoadBalancing>

    <AlwaysTunnel>False</AlwaysTunnel>

    <AddQvs>

      <Machine>qvlab</Machine>

      <Port>4747</Port>

      <LinkMachineName>qvtest.net</LinkMachineName>

      <Weight>1</Weight>

      <Username />

      <Password>Encrypted=DxdCGMWfOwU=</Password>

    </AddQvs>

  </AddCluster>

To point to your QVS server.

Not applicable

Re: dmz server configure

Hi Bill,

It seems to be correct allready. Probably by the changes i did in the QMC.

NL01is159 is Server A (where QlikView server is installed)

NL01sa010 is server B (The dmz server)

Do you see anything off in the config?

<Config>

  <ConfigVersion>11</ConfigVersion>

  <DefaultUrl>http://_/</DefaultUrl>

  <DefaultQvs>QVS@nl01is159</DefaultQvs>

  <ConfigUrl>http://_:4750/QVWS/Service</ConfigUrl>

  <TunnelUrl>/scripts/QVSTunnel.dll</TunnelUrl>

  <QvsStatusUrl>/QvAJAXZfc/QvsStatus.aspx</QvsStatusUrl>

  <LogLevel>Information</LogLevel>

  <WriteStackTrace>False</WriteStackTrace>

  <UseCompression>True</UseCompression>

  <InstallationPath>C:\Program Files\QlikView\Server\Web Server</InstallationPath>

  <QvsTimeout>60</QvsTimeout>

  <QvsAuthenticationProt>Negotiate</QvsAuthenticationProt>

  <QvpPort>-1</QvpPort>

  <EnableUtilizationLogging>False</EnableUtilizationLogging>

  <SessionCookieTimeOut>30</SessionCookieTimeOut>

  <AddCluster>

    <Name>QVS@nl01is159</Name>

    <LoadBalancing>CpuUsage</LoadBalancing>

    <AlwaysTunnel>False</AlwaysTunnel>

    <AddQvs>

      <Machine>nl01is159</Machine>

      <Port>4747</Port>

      <LinkMachineName>nl01is159</LinkMachineName>

      <Weight>1</Weight>

      <Username />

      <Password>Encrypted=DxdCGMWfOwU=</Password>

    </AddQvs>

  </AddCluster>

  <AddDSCCluster>

    <CustomUserPort>4735</CustomUserPort>

    <DirectoryServiceConnectorSettings>

      <ID>ad31104b-f413-4623-b5ae-71352867396f</ID>

      <Url>http://nl01is159:4730/DSC/Service</Url>

      <Name>DSC@nl01is159</Name>

      <Username>DxdCGMWfOwU=</Username>

      <Password>DxdCGMWfOwU=</Password>

      <LogLevel>Normal</LogLevel>

      <ShowAlerts>true</ShowAlerts>

    </DirectoryServiceConnectorSettings>

  </AddDSCCluster>

  <Authentication>

    <AuthenticationLevel>Always</AuthenticationLevel>

    <LoginAddress>/qlikview/login.htm</LoginAddress>

    <LogoutAddress>logout.htm</LogoutAddress>

    <GetTicket url="/QvAjaxZfc/GetTicket.aspx" />

    <GetWebTicket url="/QvAjaxZfc/GetWebTicket.aspx" />

    <HttpAuthentication url="https://_/scripts/GetTicket.asp" scheme="Basic" />

    <HttpAuthentication url="/QvAJAXZfc/Authenticate.aspx" scheme="Ntlm" />

  </Authentication>

  <AccessPoint>

    <Path>/QvAJAXZfc/AccessPoint.aspx</Path>

    <AjaxClientPath>/QvAJAXZfc/opendoc.htm</AjaxClientPath>

    <PluginClientPath>/QvPlugin/opendoc.htm</PluginClientPath>

    <DefaultPreferedClient>Ajax</DefaultPreferedClient>

    <DefaultView>Thumbnails</DefaultView>

    <DefaultPagesize>12</DefaultPagesize>

    <HighlightNotExecutedJobs>False</HighlightNotExecutedJobs>

    <HighlightThresholdMinutes>60</HighlightThresholdMinutes>

    <AllowCmdUrl>False</AllowCmdUrl>

    <Target>_self</Target>

    <RespectBrowsable>True</RespectBrowsable>

    <SystemMessage />

    <StatusRecheckInterval>60</StatusRecheckInterval>

  </AccessPoint>

Employee
Employee

Re: dmz server configure

HI,

No, that looks correct.  Are you using the same accounts on both systems for the service account and to run the Application Pool (if you are using IIS)

Bill

Not applicable

Re: dmz server configure

Hi Bill,

I think that you put your finger on the spot here. I'm not using IIS. but i'm not sure how to use the same accounts.

Username en Password are the same for both servers.

But on server 1 is on a domain: companydomain\qlikviewadmin

DMZ server is without active directory so .\qlikviewadmin

Do i need to do something in the services (qlikview webserver > Log on as setting?). This is currently on local

or do i need to do something with the login credentials in the QMC> edit webserver properties

Thanks for helping me trough this struggle!

Employee
Employee

Re: dmz server configure

Hi,

OK, then lets try this. On the Machine that is running QVS, try to create a local User that is the same as the user in the DMZ and use the same password. Make this user a member of the QlikView Administrator group.

Let me know what happens.

Bill

Not applicable

Re: dmz server configure

Hi Bill,

I added on both servers a new local admin account and added it in the qlikview administrator group. but unfortunately it din't help.

On the accespoint it says welcome NL01SA010\qlikadmin

NL01sa010 is the DMZ server. Is this an issue?

Not applicable

Re: dmz server configure

I found out what went wrong!

IT din't configure the DMZ server correctly. They forgot to add the domain prefix in the dns resolver. thanks allot for your help. it works yeey!