Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

amien
Valued Contributor

loop in QMC tasks possible?

I have this scheduled:

* 0. Dummy Task.QVW

* 1. QVD Extract.QVW

* 2. Transformation.QVW

* 3. Model.QVW

* 4. AccessPoint.QVW

Level 1. does have more QVW files (for each table one), so this is just as example.

4. is started to reload when 3 is ready. 3 is reloaded when 2. is ready etc etc.

What i want is that Task 0. should start when Task 4. is ready. So this would mean that this task will run forever (forget the debate if this is good or not )

But how can this be done? I have publisher and tested two things (both not working)

* Start 0 on succesfull reload of Task 4 : This will result in that task 0 and 1 will not be visible anymore in QMC. Search task in QMC works, but reload of 0. doesn't start when 4. is finished

* Reload 0 on succesful multiable events : Task 4. only. The tasks will still be visible in QMC, but task 0 is not started when 4 is finished.

Anyone got this infinity reload loop working somehow? Or is this not supported in QMC?

3 Replies
alexdataiq
Contributor III

Re: loop in QMC tasks possible?

Could you elaborate more about "task 0 and 1 will not be visible anymore in QMC."? Tasks doesn't get invisible on the QMC when trigger/run.


I don't see why Task 0 wouldn't run on success of Task 4. What happens when Task 0 gets triggered after Task 4?


Cheers

amien
Valued Contributor

Re: loop in QMC tasks possible?

"Tasks doesn't get invisible on the QMC when trigger/run."

well it does.. it has a trigger, but nut visible anymore in QMC... but when i do a search task in QMC, there will be found.

"I don't see why Task 0 wouldn't run on success of Task 4. What happens when Task 0 gets triggered after Task 4?

Well .. i start task 4 .. and task 0 just don't start.

alexdataiq
Contributor III

Re: loop in QMC tasks possible?

Maybe some screenshot of your task structure and triggers would help to get an idea of whats happening.

Are you setting the trigger on Task 0 to fire when Task 4 completes succesfully? Maybe you need to tweak the Timeout in minutes value on the tigger tab.

Cheers

Community Browser