Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

macro problem in IE plugin

Hi all,

i'm trying to run the below macro code in IE Plugin.

Using System Data:

QlikView 11 SR1 server

Internet Explorer Browser.

sub runDoc

set Var=ActiveDocument.Variables("vTest")

set App=ActiveDocument.GetApplication

set UserFile = App.OpenDoc ("http://localhost/QvAJAXZfc/opendoc.htm?document=Pass%20parameters%20in%20Web/"&vApp.GetContent.String&".qvw&host=QVS@share","","")

set v = UserFile.Variables("vTest")

v.SetContent Var.GetContent. String,true

ActiveDocument.ClearAll false

end sub

Please can some one tell me why the macro is not working.

Thanks in advance.

7 Replies
Not applicable

Re: macro problem in IE plugin

still waiting for some one's response on this post.

Thanks in advance.

MVP
MVP

Re: macro problem in IE plugin

Hi,

What do you want to do? Open a QlikView document using a button? If so, why don't you use a direct action instead? In the code above you are referring to "vApp". Such variable does not exist or is missing in your example.

Hope that helps.

Miguel

Not applicable

Re: macro problem in IE plugin

Hi thanks for reply.

sub runDoc

set vTest=ActiveDocument.Variables("vTest")

set vApp=ActiveDocument.Variables("vApp")

set App=ActiveDocument.GetApplication

set UserFile = App.OpenDoc ("http://localhost/QvAJAXZfc/opendoc.htm?document=Pass%20parameters%20in%20Web/"&vApp.GetContent.String&".qvw&host=QVS@share","","")

set v = UserFile.Variables("vTest")

v.SetContent vTest.GetContent. String,true

ActiveDocument.ClearAll false

end sub

What i'm trying to do is :

1.) in current app there is a list object which will show all the qvw file names

2.) now user will select any one qvw file name and clicks on button , then selected qvw should open in browser.

Thanks in advance.

MVP
MVP

Re: macro problem in IE plugin

Hi,

What type of directory are you using? Active Directory, Custom? Does that code work with Ajax?

Regards.

Miguel

Not applicable

Re: macro problem in IE plugin

Hi,

I'm sorry i don't know how to check which directory i was using.

Please suggest how to check my directory.

Thanks in advance.

MVP
MVP

Re: macro problem in IE plugin

Hi,

Go to the QEMC (or QMC if you are using version 11), System, Setup, Directory Service Connectors, expand and check which one of the list (Custom, Active, Configurable, etc) has a user and password set up. Check with your IT people if necessary.

Hope that helps.

Miguel

Not applicable

Re: macro problem in IE plugin

Thanks Miguel and sorry for my late response,

In my DSC, Only Active Directory and Local Directory having the Path, UserName and Password.

whats my next step to run my macro succesfully in IE browser?

when i click the macro button in IE browser it is generating an error message. how can i overcome this error ?

Macroparsefailed.JPG

thanks in advance.