Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

possibly corrupt file error when opening file in web browser

Hello,

I'm migrating QVS from version 8.5 to 9 and came across following problem:

1. I get "possibly corrupt file" and "failed to load because file couldn't be loaded [21]." error when I try to open files in internet browser. This affects ONLY files that I have opened in QV Developer and then saved. Therefore none of my old templates works. The same scenario if I open and save a demo template.
QV documents that are installed together with server can be accessed with AJAX browser.

If i enable file download option all documents can be opened locally without any problem.

2. Java application in web browser doesn't open any file - it starts loading, but stays in that state forever.

I have DMS authentication mode enabled, but that should not cause the problem as demo templates can be opened with AJAX client and downloaded without problems

Does anyone have experienced similar problems?

Thanks
/JC



2 Replies
Not applicable

possibly corrupt file error when opening file in web browser

After a support session with QlikView there are some answers to the problem:

1. Managed to get rid of the "possibly corrupt file" error. Solution was to install QlikView analyzer on the server and open the template there. Once it is saved in repository, documents were opened with no problems in web using AJAX client.

2. Java client error - this is more tricky one. Turns out there is a bug. Support were able to provide a fix to open templates in web browser using Java client, BUT only on local computer. You will still get the same error if trying to open the template over the network using Java client.

The estimate for fixing the Java client bug is next release, so the conclusion for now is that only AJAX client is working in web browser, though I haven't tested IE client as I'm using Mac.

Hope it will help someone.
/JC

Not applicable

possibly corrupt file error when opening file in web browser

Hi, i also encountered the similar problem.

when i open a file as a client it showing the following error

1. "This document is failed to load because of an I/O error or a corrupt document".

and if i check log file ,there it shows "Total memory Exhausted.Attempting Recovery."

waiting for reply...

thanks.

Community Browser