Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

chauhans85
Esteemed Contributor

print macro not working in Ajax mode


Hi all,

I have below macro.which is working fine in IE plugin but not in ajax mode.

I know this is limitation of qlikview and mentioned in Release note.but i am looking  for any work around for this.

sub test

ActiveDocument.ActiveSheet.Print

end sub

thanks

Sunil Chauhan

Labels (2)
5 Replies
vijetasharma
Contributor III

Re: print macro not working in Ajax mode

HI,

Check have you change module security,give system access to module security by Ctrl+Shift+M and also you can refer this thread to change module security on server also by using qemc

Re: Macro not working on access point

chauhans85
Esteemed Contributor

Re: print macro not working in Ajax mode

Hi Vijeta,

I know and apply all this in my app.

but its not working.

I have Print actions also. i found it working for report but not for print sheet.

using this i can resolve the print issue. but i have a new problem. like how to drag Container object in report.

Thanks

Sunil

chauhans85
Esteemed Contributor

Re: print macro not working in Ajax mode

Any reply on this?

jerrysvensson
Valued Contributor II

Re: print macro not working in Ajax mode

It doesn't work in Ajax. See Bill Britts comment:

Re: AJAX with OnOpen macro

Re: print macro not working in Ajax mode

That doesn't seem possible in QlikView Desktop, as many other community discussions have concluded before. You'll have to copy the objects inside the container to your report one-by-one.

It's not entirely unexpected (containers are still a PITA more than once), but it's a pity indeed that container objects don't allow this, because it would improve ease-of-use...

Peter.

Community Browser