Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

"Always one selected value" doesn't work

Hi,

I'm using filters with the option "Always one selected value". It works perfectly on the designer, but when I publish it, and load my application with IE or Firefox, it doesn't work anymore. It's possible to select multiple values, so the results of my calculations on filters are false.

Is it normal? Is it a bug, or is there an way to fix this issue?

Thank you in advance.

1 Solution

Accepted Solutions
Not applicable

"Always one selected value" doesn't work

Try to open your application in Desktop version with option "Without data" and reload it. And you will get the same result as you have in Publisher with "Reduce data->Remove All values". You don't need to do Remove All data because when you reload an application, the data will be removed and reloaded automatically. This option could be useful with partial load only or for some application backup functionality.

8 Replies
Not applicable

"Always one selected value" doesn't work

It works fine in my application. QVS v. 9 SR2-5

Not applicable

"Always one selected value" doesn't work

In fact, I saw that it works fine in the Designer, but when I publish the application, and re open it with the designer after the reload, "Always one selected value" becomes unchecked.

Not applicable

"Always one selected value" doesn't work

It may happen if you reload data and there is no data for the field, or there is no value in field which was current at the load time.

Not applicable

"Always one selected value" doesn't work

Thank you.

I was figuring it was a bug, because it works if you reload the application in the designer, but not in publisher mode... but it seems that it's normal because publisher reloads all the datas after flushing the application. Is it true?

Not applicable

"Always one selected value" doesn't work

My applications with "Always one ... " fields are reloaded by publisher too. And everything works fine.

Not applicable

"Always one selected value" doesn't work

This problem only happens when I flush the application by using "Reduce data->Remove All values" and reload the application in the publisher". Otherwise, when I just reload it with the publisher, it works.

When I reduce data and reload it in the designer, it also works.

Thank you for your help.

Not applicable

"Always one selected value" doesn't work

Try to open your application in Desktop version with option "Without data" and reload it. And you will get the same result as you have in Publisher with "Reduce data->Remove All values". You don't need to do Remove All data because when you reload an application, the data will be removed and reloaded automatically. This option could be useful with partial load only or for some application backup functionality.

Not applicable

"Always one selected value" doesn't work

Thank you!

Community Browser