Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

"Connect to Server" window

We have around 50 users who have installed the IE plugin on their computers and use QlikView without problem. We also have 3 terminal servers, that our users with Thin Clients use, where we have installed the IE plugin. The servers are all quite similar in their performance but our problem is that QlikView works without problems on two of the servers but not on the third. When a user clicks on a qvw-file, nothing happens for a few seconds and then a window appears, with the title "Connect to Server".

Some users have managed to access the qvw-files by clicking on "Ok" or "Connect" in the window but normally nothing happens when clicking on "Ok" or "Connect". Has anyone else experience this problem or have any idea how it could be solved?

8 Replies
vgutkovsky
Honored Contributor II

"Connect to Server" window

I've seen something similar occur when 1 user tried to open 2 or more applications from the AccessPoint in rapid succession. I think it occurs because the server does not have time to catch the previous request before a new one is sent. If a user impatiently clicks the same link twice, I suppose this error would come up too. However, I've never seen it happen consistently on 1 server.

Are these Terminal Servers also your QlikView servers? If so, are you clustering them? In general, what is the configuration?

Regards,

Not applicable

"Connect to Server" window

Hi Vlad,

no, none of these Terminal Servers is my QlikView Server, QlikView is on a server completely dedicated for QV.

The Terminal Servers are quite similar in their Hardware but have some different software installed and I guess that could be a possible cause.

Not applicable

"Connect to Server" window

Hi, habe you found a solution to that? Experiencing the same now. Thanks.

Not applicable

"Connect to Server" window

Hi Lukas. No, unfortunately it is still not working on the Terminal Server. We still haven't upgraded to the latest SR3 and maybe that will help, but I don't think so.

In the meantime we are telling all our users who need to use QlikView, to use one of the other Terminal Servers.

Not applicable

"Connect to Server" window

Hi dempen,

thanks, we have the latest SR3 installed, so that's not the cause. Will let you know if I find out the cause.

Lukas

Not applicable

"Connect to Server" window

Hi,

Did anybody find a solution?

thanks

Not applicable

"Connect to Server" window

Hi,

I guess to find out what the problem is, you have to have a look @ your config.xml and your opendoc.js .

Did you use a tunnel? Than you have to set some configuration in <AddQvs>- Tag like:

<AlwaysTunnel> True</AlwaysTunnel>
<Port>4747</Port>
..
<AlwaysTunnel>True</AlwaysTunnel>
<ProxyMode>True</ProxyMode>
<Weight>1</Weight>

Not applicable

Re: "Connect to Server" window

Hi Kemal,

We too faced the same issues here. After done the fix you suggested, it has worked like a  charm and the Connect to Server doesnot appear any more.

It was <AlwaysTunnel>False</AlwaysTunnel>

I have changed the False as True

Many Thanks

-

Yoga

Community Browser